Report

How to change from google.xx to google.com? [Solved/Closed]

Ask a question Urederra - Last answered on Oct 26, 2017 at 06:37 AM by shreenivas
Hello,

I have a new laptop bought on the USA but I am living in Spain at the moment. When I type www.google.com to use google to perform a search, it automatically changes to www.google.es That happened to me in other computers so I know that if I click "google.com in English" it goes to www.google.com. But with my laptop it immediately goes back to www.google.es and if I perform a search, it gives the results in spanish first. Searching for pictures or news is even more painful. Could anybody tell me how to change the settings so I can use www.google.com instead of www.google.es?


Thanks in advance.
Helpful
+1291
plus moins
I use Windows® Vista® and Internet Explorer 8.

I usually get redirected to http://www.google.co.nz

However, typing "/ncr" after the address takes me to that site with no redirection

eg:

http://www.google.com/ncr = google.com
http://www.google.co.uk/ncr = google.co.uk

Should be the same for other countries.
ZaeBalk 1Posts Saturday October 6, 2012Registration date October 6, 2012 Last seen - Oct 6, 2012 at 03:35 AM
The solution: Instead www.google.com use: www.google.com/ncr

Regards.
neo- Oct 8, 2012 at 09:33 AM
thanks ....
Joe- Oct 8, 2012 at 10:52 AM
For me the problem remains... even if I put the ncr behind. It says it is on google.com, but the language is not English and not the language of the country.
shreenivas- Oct 26, 2017 at 06:37 AM
super sir
Reply
Helpful
+281
plus moins
In Chrome under Options (the wrench) go to Default Search -> Manage

In the new window fill in the boxes as follows:

Name: Google.XX
Keyword: Google.XX
URL: http://www.google.XX/search?q=%s
** where XX is the specified country, in my case I used .ca for Canada
Helpful
+128
plus moins
Type www.google.com/ncr it will redirect you to your english google web site
Omiz- Mar 23, 2010 at 10:51 PM
Ya, whats up with google.hk, why can't we just have google.com.... weird...
wang- Mar 25, 2010 at 02:57 AM
i have the same problem with the google.hk, I am also in china and I am frustrated with all my searches coming up in chinese
Ritsuji- Mar 31, 2010 at 02:06 AM
haha, china so bad man, luckily I live in Taiwan, peaceful and democratic country
ringsting- Apr 5, 2010 at 02:20 AM
@Wow

you've missed the point...maybe try actually reading the problems and you won't make yourself look like such a donkey

i too am annoyed that all my results are coming up in Chinese, even with vpn on
otheroption- Apr 15, 2010 at 03:30 PM
what about www.google.co.uk
Helpful
+64
plus moins
I did the following with Firefox and worked from three different countries:


1- Set Firefox's Home Page to http://74.125.127.100/

For example, Tools --- > Options --- > in the Home Page blank paste (http://74.125.127.100/)



2- In the top right corner of Firefox where the different search engines bar, click on the little down arrow, then choose Manage Search Engines. It will open up for you a new window. At the bottom of this window, click on "Get more search engines".

It will open for you a add-ons page, write in the search box "google" to narrow the adds-on. then scroll down to an add-on called "English language-specific Google search". Click on Download now and your are done !


Greetings
Hani J.- Mar 6, 2010 at 08:54 AM
PERFECT " I meant to put it in upper case" as I was really really annoyed by this for the last 5-6 days...

Bandar suggestion was the ONLY solution to the problems most of us face..
regarding Google redirecting to a country specific home page.

Thank you so very much...Brilliant..


Cheers
DeadEnd- Mar 13, 2010 at 12:22 AM
There is a way and I just solved this issue,

go to your hosts file in c:\windows\system32\drivers\etc\hosts

open the file with administrator's privileges

and add the following entry at the end of the file and Save it.

74.125.127.100 www.google.xx (xx your extension according to your country)

one done, try www.google.com with IE, it will always open the English website.


Regards,
Deadend
dlkool- Mar 28, 2010 at 05:09 PM
Thank you Jerald, that works for me.

David L.
MusasiDude- Apr 11, 2010 at 07:20 AM
Worked perfect, thanks!
Notamember- May 10, 2010 at 11:56 PM
Add the Google Search provider that links incorrectly for me it was Netherlands then go here.
http://www.microsoft.com/windows/ie/searchguide/en-en/default.mspx
Follow the instruction in the orange box and click install... when it pops up it will ask if you want to make the provider your default check the box and click replace.
This will modify the url the provider is using but maintain the ability for it to guess your search.

Hope it helps
Helpful
+52
plus moins
Use http://www.google.com/ncr where ncr equals "no country redirect"
Helpful
+37
plus moins
Hi, I tried this and this worked on OPERA 10.1.

Click "Tools" Tab
Select "Preference"
Click "Search" Tab
Remove "Google" from the list
Add "Google" from the list
Click "Details"
Copy and Paste this:

http://www.google.com/search?q=%s&sourceid=opera&num=%i&ie=utf-8&oe=utf-8

Close the screen


Just trry to search using Top Right Panel using "Google"

Let me know if this work of not on your system.

Cheers,

Liem KF
Fohsap 1Posts Monday October 22, 2012Registration date October 21, 2012 Last seen - Oct 21, 2012 at 11:14 PM
Alternatively:
1) Magnifying glass drop-down; 2nd-to-last option (add providers); top, right-hand side change the website's language to Engilsh/Spanish/whatever; add google/yahoo/whatever, and it will be in your language.
2) Magnifying glass drop-down; last option; right-click desired, first option; right-click undesired, press m.
Helpful
+22
plus moins
hi,
Normally on the home page you can see a link below the search box for google.com. no matter where ever you are

hope this helps
Helpful
+20
plus moins
Unfortunately this is neither an ISP, Microsoft, or country-related issue. This is specifically a Google-related issue (if you want to identify it as an issue). When you go to Google's website it identifies your IP address and automatically determines which country that IP address is coming from. Once it determines that it will automatically redirect your page to the specific Google page they have created for that country. Google is able to identify the countries where websites are published, thus, it will prioritize your search results to the country where you are doing your search.

This is a smarter and better method by Google to provide people the best results possible. Obviously, for some people, specially tourists or people who simply want to search U.S. websites, this is annoying.

Now, to answer your question, there is a work-around for this. Not a solution but a "work-around". There are internal monitoring or scripting software out there that has the ability to monitor, for example, the websites you go to and automatically redirect it to an alternate page when it detects it. These are more effective as a parental control feature but you may use it for this specific cause.

What I use is AUTOMATE but this is quite a complicated software for beginners or non-IT people. You may configure Automate to block http://www.google.com.xx and automatically redirect it to http://www.google.com.

There are, of course, other alternatives out there, some better, some more complicated, and some that just doesn't quite hit what you truly want (like the Google.com in English link on Google's page). Hence, that is an effective workaround to your issue.
Helpful
+13
plus moins
Hello,

When I write www.google.com so it's automatically open www.google.co.uk...i did try many times for solve this problem, but it's failed...if u have solution for this problem let me know...

Thank u
wonleka- Jul 5, 2009 at 04:15 PM
The advice above your post worked for me! I understand what you said, about needing to get to google.com in the first place in order to do that, but infact you will notice that all the google pages e.g. google.es, also have the option of selecting "Google in English" (bottom right). Hope it works for you too. I made it my homepage as soon as I was there, and after opening my browser again, its still there.. yahh:)
Eb- Dec 28, 2009 at 02:30 AM
ME too! So frustrating!
Serah- Mar 12, 2010 at 04:48 PM
I had the same problem .. I am a Canadian living in Mexico so the search comes in Spanish.
Solution: 1. Create an iGoogle account.
2. Go to the settings in ur iGoogle page.
3. Change your current location "in my case to Canada".


At this point, it should change to the language you want.
TamboGirl- Apr 20, 2010 at 06:48 PM
hey thanks, Serah, that worked. I am in Costa Rica and accidently got rid of my English Google Toolbar and when I went to install it I went to http://www.google.com/intl/en/, thinking that will bring up the Google Toolbar english version but nope it didn't work. but what you figured out worked and I wanted to thank you for taking the time to write it.
Awesomeeee- May 5, 2010 at 07:55 AM
@Serah

Thanks that worked.
Helpful
+12
plus moins
I have already tried that. Doesn't work either. Everything tried so far ended up with www.google.es instead of google.com as my browser.

The funny thing is that probably somebody at google thought that changing the google front page depending on the country was a good idea. :(
Helpful
+12
plus moins
hi,

check on this video, It has the solution

http://www.metacafe.com/watch/1486710/connect_to_google_com_with_no_country_domain/

if you get google with someother domain eg: google.co.uk >> plesae check the bottom line in it where it says "go to google.com"

Hope it helps,
Helpful
+11
plus moins
From Google Support:

Trouble connecting: Google.com automatically takes me to another Google site
Helpful
+10
plus moins
I think I can solve this problem for at least the default search in Internet Explorer 8.

On the search field in Internet Explorer click on Manage Search Providers and delete all names of google. If you havent added more than google then you should at least one more temporarily that is by clicking on Finding more providers and choose for instance Yahoo Search and set it as default and then you can delete Google.

Ok now in find more search providers page there is a link which is Create Your Own Provider

By clicking on it you see three fields which is URL, name and encoding.

In URL enter

http://www.google.com/...

and name it like Google English

Keep Character Encoding as whatever appears and save it....


This fixes my problem and now whenever I search on google from Internet Explorer I dont see the dreaded language pages and search in English and it doesnt display anything else.

If you screw up or it doesnt work simply add Google from more search providers and set as default and delete this one you made and you can go back to how it was before.


I hope this helps.

Waseem.
Helpful
+9
plus moins
If you login as a Google user and set your preferences, they should stay the same no matter where you are. Does that not work for you?
Helpful
+9
plus moins
I do have the same problem since yesterday when I changed my keyboard to include the Spanish set. I thought I only changed the keyboard layout and since then, every time I go to google.com (whether using Internet explorer or Firefox), it automatically changes to www.google.es. I checked the date on my computer and it is July 24, 2008. If you type http://www.google.com/intl/en/, then it goes to the English version. It suchs, though, because www.google.com is NOT www.google.es and there is no reason why we have to go to all that garbage to get a basic website. I know that www.yahoo.com does not have any issues with that.
Helpful
+7
plus moins
Damn, Damn Damn!!!!!!!!!!!!!!!

I have tred safari and I can't access to google.com either. It is a vista preferences thing. From now on, I HATE windows. For some weird reason somebody at Microsoft thought that not allowing people at other countries to access www.google.com was a pretty neat idea.
Someone else- Apr 28, 2010 at 06:45 AM
Yea, lets blame Microsoft. Unbelievable!
Helpful
+7
plus moins
u go to setting
then option
then u see default search
click on manage
click on google.es and a small bar will come out
erase the es and put .com
then press ok
do that three times and then restart com
and go to mange ang you will see the google icon
then close broser and open it again and search for something it will work
XD
Helpful
+6
plus moins
Problem solved!!!

Apparently, my computer date was set up on 1 January 2013 or something like that, and all the sites that needed a time certificate refused to load on Safari and need a reconfirmation on IE.
JA- Apr 4, 2009 at 01:37 PM
Hi,
Can you tell me how you solved that? I'm living in Sweden temporarily and been getting the problem as of today! It was not like that before! I can't read/speak Swedish so my google is useless!!!
Helpful
+5
plus moins
I use Linux , I'm in the US on a US server and everything has worked fine for the past year until I installed Google Chrome. Uhm... IE. it's Google Chrome's fault. it redirects me to google.co.uk which is really weird... all of my settings are set to english, my region is set to US, my google preferences are set to english. It is really puzzling that it would redirect my www.google.com to google.co.uk

With all that said, www.google.com/ncr fixed my problem.
Helpful
+5
plus moins
use this as your homepage

http://www.google.com/webhp?hl=en&complete=0

and for the search bar get an google.com (in English) add-on
1 2 3 Next

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!