Unable to connect to my linksys wi-fi router [Solved/Closed]

ninja - Sep 30, 2008 at 06:29 PM - Latest reply:  budz
- Dec 6, 2012 at 10:03 PM
Hello, unable to connect my iphone via my linksys router
See more 

95 replies

+57
Helpful
28
Ok I figured it out

If you keep getting "incorrect password" using your Iphone when trying to connect to a Linksys (WRT54G) Router.

Try typing in the WEP "key 1" numbers (not the actual password or passphrase)

They are located in the "wireless security" settings.

1. Go to 192.168.1.1

2. Enter "admin" for both username and password (actual one NOT "key 1" numbers)

3. Go to Wireless/Wireless Security and they should be right there.

4. If Default Transmit Key "1" is marked use "key 1" numbers, if "2" is marked use "key 2" numbers, etc.
Was this answer helpful?  
THANK YOU! worked!
It worked for me too
You are the man,, thank you very much its working fine now
Many thanks! It worked for me too after I spent hours searching for information!
if your connections are discoverable but you cant connect..just go to control panel > network and sharing center > manage wireless networks then click properties of what router did you use if you know the password but if you cant connect,just replace the new password on the security tab of your router properties..maybe it has changed..thats for computers and laptops..for others like cellphones of ipod's just restore your network settings then connect it will ask you again for a password then enter the correct password..it will connect you to your router 100%..ahaha thanks..
+13
Helpful
7
Ok, I found a few ppl with solutions to this problem, none of which worked for me. I tried resetting the phone under settings, and tried turning the Wifi off for a while and then back on, but to no avail.

I don't know if this will work for you, but it worked for me:

Changed the Wifi channel on the router to a lower one

Once I did this it started working immediately, and the Wifi signal strength was even much better than before.
does this work for linksys?
does this work for linksys?? thats what I have just I dont need a password. PLEASE I NEED ANSWERS AND SOLUTIONS!!
ZOMG111 CAPS MAKES THE ANSWERS COME FASTER!111!!!
Thank you Somme1 I had tried everything on here to connect my Iphone 4 to my Linksys WRT120N wireless router to no avail. And then I tried your solution I lowerd my wifi channel and the phone instantly connected. Thank you for your input I was about to return the router
Thank you!!!!! Lowering the channel worked for me. Whew! Hours wasted on this. So happy it's finally working!
+7
Helpful
9
Here's what worked for me. Go to iPhone SETTINGS > GENERAL > RESET > RESET NETWORK SETTINGS.

It seems that the Upgrade process in iTunes has some variability. My friend had to re-enter their password. I wasn't even being offered the opportunity to enter one.

Tried everything logical and then resetting the network settings provided the Eureka moment. I hope this helps
thank you, it worked for me
Thanks! After trying many other things that did not work your reset worked for me with an iPod touch with software version 4.0 and a Linksys WRT110 N router.
Wow, this actually worked. So happy :)
It works! After racking my brain for several hours I ran across this. Have an Ipod touch and it would not allow me to put a password in it just would automatically connect without the password! It works if you reset your network settings!
i just did it and now it says in correct pasword when tis the rtie password!
+4
Helpful
1
iphone doesn't support 802.11 N wireless network. check if your router is set at 802.11n. dumb as it sounds, but iphone can only support 802.11g
I have a ds and it says only compatible with "b" router. My router doubles as g and b, worked for a while, then all of a sudden it didnt.
+4
Helpful
2
hi


Make sure you know the password if your wifi is secured.Second check the wireless mac filter on the routers page maybe mac filter is set to enable thats why you cant connect your iphone to your wifi
perfect that worked out immideately
thanks..it worked
+3
Helpful
3
On a Belkin N1 Wireless Router, you add the mac address of the iphone to your list of allowed mac addresses. Simple. You can find the mac address of the iphone under general settings. Worked for me
hi, I dont know where is iphone Mac address? can u help me?
I did the same thing and it worked for me also. I am using a Linksys WRT120N router
worked for me as well, thanks!!
+2
Helpful
1
I had the same issue and this fixed it:

I found a solution from a friend: You disable the password and let the iphone connect to the router. Then you put the password back and now it will accept the password.
I tried what Tiskilwa suggested and it still doesn't work for me. When I have password activiated I can't connect using my iphone. It tells me password incorrect even though I'm putting in the exact password. When I disable the password I then can get access though.
+2
Helpful
1
Loboblast's advice worked!

For WRT120N Linksys users, you should grab the network security key stored in the text document on your desktop after configuration and use that as your password for connecting to your home network.

Thanks!
thank you so much! I been fighting with my router for 2 months , I been doing what everyone else has been telling me and I gave up, I seen your post , I dont have the wrt120n I have the wrt52g so I thought I would try it anyways and it worked!
+1
Helpful
OK, this is how I resolved it for my Linksys Model no: WAG32ON, it may work for others as well:

1. Go to http://192.168.1.1
2. go to wireless tab.
3. go to wireless security.
4. change security mode to WEP.
5. write a 10 digit number in the passphrase box and hit "generate".
6. Some keys get generated; I used Key 1 on the iPhone when it asks for the password and it connected immediately.

All the best!
langener51 20 Posts Thursday May 1, 2008Registration date May 10, 2009 Last seen - Oct 1, 2008 at 03:28 AM
0
Helpful
3
are you sure that your linksys is properly configured and also doesnt need any wep key?
I setup a home network sometime ago and all was working fine, i.e., ethernet as well as wifi. I configured the wireless as WEP. All of a sudden, only in certain places in the house could be connected, and eventually not even sitting right next to the router. I have done a manual reset (unplug router, then modem, wait 1 min. plug modem back in, once totally connected, plug in router) with no difference. Have double checked that Homegroup is set to mine. I am currently running Windows 7 Home Premium 32-bit.
i just hit renew Lease
0
Helpful
Did you find any solution? I am having the same problem
0
Helpful
Hey,
Im having trouble getting my netgear router to have wireless internet. can someone help?
0
Helpful
13
I had similar trouble when trying to connect to my ipod touch to my home wireles (lynksys) which is secured by a password. My ipod touch asked me to enter the password for the network. What I finally discovered is that the password to enter is not the password that you created for the wifi but it is actually the network security key which lynksys provided when you purchased. Very frustrating. Anyway it works now! To find the network security key go to http://192.168.1.1, click on "wireless", click the sub-tab "wireless security". The "passphrase" is the network security key and is what you should use as the password for connecting the ipod touch to the wireless.
I should add that when the 'password' prompt came up on my iPhone, all I typed in was
CxxO3h2cG9gnVjSy - the actual security key is 20characters long.

Hope this helps!!!!
Marykate
Thank you so much. I was using our regular password not the huge security key # to connect on my itouch. It works perfectly now. Thanks again BB.
With Linksys router, you need to make sure that the settings on the "Wireless MAC Filter" tab are not preventing your iPhone from accessing the wireless network. As the password, I just used the WPA Shared Key (as I thought), but I needed to disable the Wireless MAC Filter for the iPhone to get access.
ahhhh I was going round and round and round trying to figure why I couldn't connect an iphone to my wireless g router. I also have an N router - iphone 4 won't work with N on 5ghz - this post reminded me i'd also set up mac filters! thank you thank you thank you!
Thank you this worked for me!!!
0
Helpful
1
Hi All,

It works for me after I changed the wifi channel to another one instead of Auto.
Thanks for Somme1 comment!!!
does this work for linksys?
Touched by an iPod - Apr 18, 2010 at 02:42 PM
0
Helpful
It was so obvious it only took me 2 solid days to figure it out :-)) I had Mac filtering enabled! Once I figured that out and found the Mac address of my ipod touch everything worked!!
0
Helpful
Change the network mode to Mixed in Linksys WRT300N. The iphone can connect to the wireless right away!
0
Helpful
I tried lots of time but my wireless doesn't show me any wireless network.
0
Helpful
I had this problem with a new 3GS and a linksys WG54 router. I turned off wifi wifi on the iphone then went to my home wifi network wi fi network and in settings clicked forget this network. Then I re-entered my wifi network password password and I could connected again to safari and my e-mails straight away.
Best, Woolfey
0
Helpful
Thank you Thank you I spend a few hours looking for the anwser and there you go problem fix thanks again :-)
0
Helpful
I have a Cisco WRT120N

1. Go to http://192.168.1.1
2. go to wireless tab.
3. go to wireless security.
4. change security mode to WEP.
5. write any password you chose and then hit "generate".
6. This will take a few seconds when done use the 10 digits under "Key 1" on the router as your Wifi password on your iPhone.

Also make sure that you Wireless MAC filter is disabled, found under "wireless" and then "wireless MAC filter"
1 2 Next
unable to connect to my linksys wi-fi router - page 2