My videos does not play when i store them in my usb flash drive [Solved/Closed]

abubatoure 2 Posts Thursday April 23, 2015Registration date April 23, 2015 Last seen - Apr 23, 2015 at 06:47 AM - Latest reply:  Cal
- Nov 27, 2017 at 06:30 PM
Pen Drive / Flash Drive/ SD Card Ask a question Report Reply to this topic
I format my Sony Vaio usb2.0 flash drive of 1.9TB .at first when I slot the usb it ask me to format it and when I did with a : system files FAT32. I finally format the flash drive and store my videos or any files in the flash drive the Videos does not play and the same thing happens when ever I open my files in the flash drive it does not open with the same Words that I personally wrote. Can any body please help me?
See more 

8 replies

+39
Helpful
2
I'm afraid you've bought a fake flash drive. I know, because I've just done the exact same thing! ¯\_(ツ)_/¯

It turns out I bought a dodgy 2TB flash drive from eBay with a tampered capacity - what was supposed to be an amazingly large drive was in fact only 8gb, though it showed the faked size in Windows and on a sector scan. I've learned there's currently no such thing as a real 2TB flash drive. Not even close.

This set me straight: http://www.ebay.com/gds/All-About-Fake-Flash-Drives-2013-/10000000177553258/g.html

What tipped me off was when I copied across about 20gb worth of .mkv files. I found that some of them were working fine, and then everything after a certain point was broken. They were broken even though the file sizes appeared correct, and there were no error messages during the copy.

I tried all sorts of things to fix them - scans, chkdsk etc., but came up with nothing. Sometimes after disconnecting and/or restarting it would accept an extra 1gb video, and it would play while it was still plugged in, but then when I ejected it and plugged it back in that file would be corrupted, as if all of the metadata was gone.

I finally figured out that it was the first 8gb that worked, and everything beyond that was faked. I feel like a total idiot for wasting so many hours, when in the end the answer was obvious - it seemed way too good to be true when I bought it, and it was.

It's one possible reason some of your files will work, but others won't, when there appears to be no rhyme or reason as to why. Hopefully this will save you (or someone else) from wasting time trying to figure out why the universe seems so random and cruel. ;)
THanks it helps me a lot, i did examine with the video files, the last one was not played so i again delete all files and copy first the last which though damage then it works. what a waste of time coz of this fake flash drive, i bought 12 nos for present supposedly.
dam the same thing happen to me, i am careful buying on ebay now.
Boogieman_WD 275 Posts Friday October 10, 2014Registration dateCertified CCM ContributorStatus October 19, 2016 Last seen - Apr 23, 2015 at 10:40 AM
0
Helpful
4
Hey there abubatoure.
I guess you mean GB instead of TB. Try the flash drive with another computer or device to see if the same thing happens. Try reformatting it with another computer. Some manufacturers also offer formatting tools for their USB flash drives and memory cards so you can try that as well.
You could also try if the flash drive acts the same in different USB ports - 2.0 and 3.0

Unfortunately there's always the chance that the flash drive might be failing if nothing works for you. :(

Please let me know how everything goes.
Boogieman_WD

WD Representative
abubatoure 2 Posts Thursday April 23, 2015Registration date April 23, 2015 Last seen - Apr 23, 2015 at 01:09 PM
Thank you for time and effort that you'v had to help me.I will try it on another laprop and see. No the USB is not GB is TB
Boogieman_WD 275 Posts Friday October 10, 2014Registration dateCertified CCM ContributorStatus October 19, 2016 Last seen > abubatoure 2 Posts Thursday April 23, 2015Registration date April 23, 2015 Last seen - Apr 24, 2015 at 10:57 AM
Then I guess this is an external HDD and not a USB flash drive. In this case I'd recommend that you download the HDD manufacturer's diagnostic tool (or a third party diagnostic tool if the manufacturer doesn't offer one), so that you can test the drive and see what's the situation with it.

Please let me know what are the results of the tests.
Boogieman_WD
You know what happens when you Assume - Sep 20, 2015 at 10:52 AM
I also have a 1.9 TB flash drive, not external hard drive. Stop assuming the poster is wrong.
Boogieman_WD 275 Posts Friday October 10, 2014Registration dateCertified CCM ContributorStatus October 19, 2016 Last seen > You know what happens when you Assume - Sep 23, 2015 at 08:39 AM
Hey there.

I'm sorry if this is the case. I was truly unaware of the existence of such a flash drive. Especially a USB 2.0 flash drive, because it sounds like the technology allowing that kind of capacity for NAND memory devices really seems like it has skipped a few steps in order to be available for a USB 2.0 device. I'd strongly recommend that both of you check the legitimacy of your devices in order to make sure that they're not counterfeit. The best way to do that is to contact the brand's customer support directly.

Please accept my most sincere apologies if it turns out that I've been mistaken. And please let me know how everything goes.

On other hand, if things turn out to be the other way around, this might be the reasons for OP's USB flash drive issues.