Can't play newly transferred videos in usb after inserting to another device [Solved]

Report
-
 someguy -
so here is how it goes:
I have a 500GB SanDisk USB, when I transfer videos in it, the videos work.
after transferring the videos to our Affordabox (basically, like a cable box or DVD box) the videos in the USB still work.
I reinsert the USB to my computer, test the videos in it, and they still work.
BUT when I transfer new videos in my USB after the above mentioned have already been done, the new videos won't work, they will continue to load indefinitely and when I try to play the newly transferred videos in our Affordabox, it would say that it is an unsupported file.
pls help
P.S
the usb gets repaired if I format it but will have the same issue again if I do the above mentioned

1 reply

Posts
52
Registration date
Tuesday June 30, 2020
Status
Member
Last seen
September 28, 2020
32
By default, Affordabox can play AVI, MPG, DAT, VOB, MKV video files. For a list of supported file types, visit the Media Types page.

https://www.gmanetwork.com/affordabox

Once installed MiniTool Video Converter (https://videoconvert.minitool.com), open the program and follow the prompts to convert the video file to a supported format. And then you can just enjoy your video via a usb on Affordabox
1
Thank you

Glad we were able to help! Love us? Write us a review! Rate CCM

CCM 2942 users have said thank you to us this month

I think your misunderstanding something...
the videos work, the videos are of the right format and they play just fine on the Affordabox,
the problem I'm having is when I add new videos to the usb.
the new videos are of the right format and they work just fine but when I insert in the USB, they won't work anymore.
I also tried to move previous videos in the USB, transferred them to my computer and re-transferred them back to the USB but then they suddenly don't work anymore.
Posts
52
Registration date
Tuesday June 30, 2020
Status
Member
Last seen
September 28, 2020
32 > someguy
I meant you can just try to convert the music format to any other it supported by Affordabox and see if it is playable, thank you!
>
Posts
52
Registration date
Tuesday June 30, 2020
Status
Member
Last seen
September 28, 2020

thank you for the help but it didn't work.