Mouse scrolling doesn't work right

jamesahner Posts 1 Registration date Monday December 6, 2021 Status Member Last seen December 13, 2021 - Dec 13, 2021 at 08:03 AM
HelpiOS Posts 12840 Registration date Friday October 30, 2015 Status Moderator Last seen October 3, 2022 - Dec 13, 2021 at 08:59 AM
This is a problem Iv'e seen multiple questions about but all of them mostly got answered by answers that don't help me, hence I'm asking my own.

Iv'e been having this issue with mouse for a while now. When I try scrolling with the wheel (in any program or window) it's kinda bugy as it often starts scrolling down-up-down-up when I'm only trying to scroll down. And sometimes it just wont scroll at all. Sometimes it just starts working perfectly but only for a while and then back to this weird erratic behaviour.

The first time I had that issue with a Logitech m500 mouse and couldn't fix it, so I got a new mouse after that (MS Wizard) and that one worked perfectly for few weeks and then I got the same problem on it.

I tried pretty much every solution I could find on the internet and nothing worked.

Things Iv'e tried to fix this:

1. Getting a new mouse
2. Messing around with mouse options in control panel
3. Scanning entire PC with antivirus and antimalware programs to make sure it's not infected (nothing found)
4. Un-pluging the mouse and plugging it back in
5. Unistalling the mouse driver and restarting PC
6. Used air compressor to blow out any possible dust or whatever from the mouse, thinking that might of caused the erratic behaviour with scrolling
7. Used system restore point to rollback to the time when mouse wheel worked normal

I really don't get it what's the problem and why is this happening. And what are the chances this happens on TWO mouses.

1 reply

HelpiOS Posts 12840 Registration date Friday October 30, 2015 Status Moderator Last seen October 3, 2022 1,827
Updated on Dec 13, 2021 at 09:05 AM
Hi,

Do you get the issue with a different USB port?

Can you check in the advanced power settings in Power Options, the USB settings. Make sure the USB selective suspend setting option is disabled.

Also, do you see devices with a yellow triangle in Device Manager?
0