Unable to access files in USB hard disk drive

Solved/Closed
LGA - Jul 10, 2008 at 07:51 AM
 boy_baboy - Oct 10, 2017 at 05:06 PM
Hello,
I am unable to access files in my USB HDD after a few minutes of operating it. If I try playing a movie, it will run smoothly for around 5 min max and then gets stuck. If I close that and try to access files anywhere in the drive, nothing will be there. Sometimes I can view the folders but not files within it. An error message "Delayed Write Failed" appears near the system tray (where the date is displayed).
I have used this device on several computers. I think it got infected by some virus or so.
Can anyone suggest a remedy for this.

5 replies

I do a lot of personal work on my computer at work, searching the internet and downloading stuff.
I've had problems with USB flashdrives from time to time not showing up as a storage drive in My Computer, while if you go to:
Control Panel / System / Hardware / Device Manager / USB Controllers
the device is listed as present and working.

When that's the situation, it sometimes works to disable the device, unplug the USB drive from the computer, and then plug it back in. (You might have to go back to USB Controllers and re-enable the device.)

Anyway, I just had a problem with a hard drive plugged into a Vantec Hard Drive Docking station that was plugged into a USB port. Again, the hard drive was present in Device Manager under Disk Drives, and USB mass storage controller.

I was able to enable this hard drive by re-assigning a new Drive Letter to the drive:

Control Panel / Administrative Tools / Computer Management / Storage / Disk Management

If the drive appears in the list select, click to highlight the appropriate drive.
From the Menu Bar select: Action

A drop down list opens and select: All Tasks
Change Drive Letter and Paths

In the box, select a new letter to assign to the drive, and then click OK, and exit.
19
Hi Robert, thanks for your answer. I think it works until the point when I try to click on "Action" in the menu bar in the Computer Manager. I try to click on the USB drive and find "All Tasks", but it does not seem to appear. I try it again for the C: drive in my computer, and this time it shows up there. I wonder if there is still a step to do before I can see "All Tasks" and "Change Drive Letters and Paths" in the menu?

Thanks!
AY
0
FANTASTIC !! It worked!! I have been unable to use my external HD and your advice on how to rename (subsequently reformate) the drive was just the answer I needed!
0
thanks Robert for the advice...
appreciated a lot n I can used my external hard disk already ...( huh 500gb additional)
gee thanks
0
Hi Robert, great advice, it works!

I had bought a new HDD and when I formatted it, I didn't assign a new driver letter! Anyway, I had to use 'USB Viewer' by Nirsoft to remove dodgy USB references then followed your instructions. Many Thanks.
0
My generic white label 500gb 2.5" external drive would register in the items listed as "able to be removed " but no where else . Following the instructions listed for initializing ,formating and naming conventions worked perfectly for this problem.
0
you need to right click on my computer and go to drive management and manually assign a drive letter to the drive
7
I also have the same problem, however the drive does not show up in my computer or windows explorer. It does show up in device manager as a usb mass storage device.

Bill
0
nothig shows up tho wat should ii do {OMG}
0
thanks man, it worked !
0
hi robert...

i do the step that you guide.. but...
the device(my external) is not listed after C: drive
it is only C: drive..

and below the frame...
it shows that got another partition it shows which know as :Disk 1, Unknown, my external size and Not initialized:
even the window already did for me.. but he result is nothing...

i did try the action step... but All Task only show the disable New Partition and properties...

Help me..
6
I had the same problem as a usb disk stick etc would not show up in MY COMPUTER but would be in disk manger assigned with a drive letter and all. If I rebooted with it pluged in it would show up okay. After much troubleshooting and checking drivers etc I CORRECTED THE PROBLE. I went into services and found the term WINDOWS MANAGEMENT was disabled. I put it in auto and turned it on and finaly got rid of the problem.
5

Didn't find the answer you are looking for?

Ask a question
thanks it work :D
kewl :D
3