My Multiplayer Call of Duty 4 is not working! [Solved/Closed]

Registration date
Friday January 18, 2013
Last seen
January 18, 2013
I have just bought Call of Duty 4 and a new laptop. When I try an go on singleplayer it works perfectly, but the problem comes when I go on multiplayer. I start to load it up, it starts up but then it says 'iw3mp has stopped working'. What do I do?

My Computer specs;

Sony Vaio VGN-NR21Z/S Notebook Core 2 Duo (T8100) 2.10GHz 3072MB (1x2GB + 1x1GB) 250GB 15.4 inch WXGA TFT DVD±RW DL/RAM Modem WLAN Vista Home Premium (nVidia GeForce 8400M GT 128MB) - Silver


15 replies

Its a glitch on vista, just plug in a headset and mic before you run cod4 multiplayer and it will work
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2942 users have said thank you to us this month

Awesome fix man, couldn't figure it out for nothing, thx!
hey mate
my call of duty modern warfare 2 isnt working for multiplayer, yet singleplayer works fine
ive tried plugging a headset/mic in but it still doesnt work
any ideas on how to fix it?
Thanks Man at the moment im trying headphone and an old mic, I cant find my mic though I have plugged the headphones into mic socket and it atleast start up now but now it gives me an error is this beacause there is not both of them plugged in or is it because its dodgy and giving me errors? it would help if any1 could solve this Thanks

p.s (it doesn't show servers either)
when I load it up it says unable to find image rpg_7 any ideads onto fixing it?thanks jak
I have the same problem, but once I click 'Join Servers'. Plugging in the mic does not do a thing. Somebody please help!
Go in your control panel click in the sounds option then right click the epty white box and click disable thing first one. and go in mic. and activate sterio.
Don't know why my last message got deleted? It was perfectly reasonable and was the answer to this problem. Well if this help, and isn't deleted! You need to go to hardware and sound. After this go into sound. There will be 3 tabs within this window. Go to the recording tab. In here you should see something called stereo mix. This needs to be enable or disabled depending on what it is already set to. I hope this helps. It worked for me and my friends.
can't find this on vista?the problem still persists with the erorr report now not imp3. has stopped working
Thankyou so much hazzjazz I just bought a new vista set and when I got call of duty it wasnt working and I was really getting angry so thanks. Cheers
sorry this thread is so old, but when I do what you say, the stereo mix doesnt show up.
Registration date
Friday January 18, 2013
Last seen
January 18, 2013

People Of world who ever is having troble with COD4...just recover your computer and then install COd4 again and it will work perfectly...

and when you start to play me in multiplayer my name is Dark_knight...

Here is the fix. Go to my computer / devices then disable your sound card. Then go in COD4, ALT+TAB, then enable your sound card again. Then go to sound settings in COD4 then click through the sound cards until it goes back to the one it was set for... I believe is milesfast 2d audio... then it should be working fine.

I forgot to add.. once you click through the sound cards and click on the one you had before.. you must hit apply. Good luck.
hey, dunno if u solved it yet, think you might hav, but if u hav no headset and mic, try this. go into control panel , then into hardware and sound, then into sound, then into the tab which says recording. in this section there is usually a thing called stereo mix. disable or enable it depending on what it is already set to. it worked for me and 5 m8s. good luck. :)
hi, im using windows7 and had the crashing at the start... tryed all the other methods till I came to hazzjaz's solution and after hours of trying to get it working I shat my pants when it saw the main menu... thanks heaps


Believe it or not, I just upgraded to Windows 7, myself, and encountered that issue.

On a tip from a forum like this one, someone suggested that I plug in the headphones and a microphone. Not having a headset, I got out a microphone from my stereo equipment that had the same size mic jack as the PC. I plugged it in. My headphones were already plugged in.

Oddly enough, IT WORKED!

I then closed Modern Warfare, then pulled out the MIC, then restarted it. It didn't work!

I plugged the mic back in, and it worked, so I just have the mic plugged in all the time now.

I was totally skeptical that this would work, but I think you should try it. I think I know the type of programming error that caused it. Windows 7 may have changed one or more multimedia instructions, making the subroutine that checks the mic work differently. A patch from Activision should fix this, but it's not a serious issue. Just plug a mic into the Mic jack, and you should be back to your killing.
Just plug a mic in your pc I dont no why it works but it dos with mine hop it works :)
Dam plugged in my head set and it worked first time. thanks people
Thanks so much Mark!!!
i would like to thank mark for the help I did not know there was a glitch on vista. and now I can play multiplayer!
You wont believe this but.. plug in a mic.. ys a microphone.. I has something to do with the sound and audio settings interfering and a mic does a good job of fixing it.. look around the net for some advice so u dont have to plug a mic in all the time but it worked for me and yes I know its almost un believable
its insane, I searched for hours when I got cod4. and yes this actually does work, some sound cards like Realtek ones. mainly realtek have problems with it. anything with the 2.5mm jack will work not just microphones. but something has to be plugged into it when you start the game.

Omg thanks you soo much mark ;)

Subscribe To Our Newsletter!

The Best of CCM in Your Inbox

Subscribe To Our Newsletter!