Itunes won't detect Ipod Classic [Solved/Closed]

AJ10 2 Posts Wednesday December 30, 2009Registration date December 31, 2009 Last seen - Dec 31, 2009 at 02:22 AM - Latest reply:  Steven
- Apr 19, 2010 at 09:13 PM
Hello,

I have spent approx. 7 hours trying everything from apple suggestions and all other website suggestions.

I have reset my ipod classic 80gb at least 10 times.

The Ipod is recognised on my computer and when I plug in the Ipod it opens Itunes but it is not detected as a device.

I have also tried several usb cords etc. and removed all virus scans.

Any help would be GRATEFULLY appreciated as I feel I'm going insane.

Thanks in advance

Configuration: Windows Vista Internet Explorer 8.0
See more 

8 replies

Best answer
noSoBigAppleFanAnylonger - Jan 24, 2010 at 10:23 AM
7
Thank you
Hi there,

Lots of good ideas out there. My iPod classic 8GB all of a sudden stopped being recognized by iTunes 9 and the strange thing happened that my wife's exact same model would work just fine.

Long story short. I installed iTunes 8.1.0.52 (found it on brothersoft.com. That immediately recognized my iPod and the 1.0 firmware which is outdated and seems to be the root cause. After updating to the latest 1.1.2 firmware (for my particular model) it is now again recognized in iTunes 9.

I did remove ALL Apple programs from the main computer and did a total reinstall of iTunes 9 but unsure if this made any difference.

Very disappointed with Apple after this experience.

Bottom line: Try installing an other iTunes version and updating the iPod firmware and see if that fixes the problem.

Thank you, noSoBigAppleFanAnylonger 7

Something to say? Add comment

CCM has helped 1704 users this month

Same problem here - Ipod Classic 30MB couldn't be recognized by Itunes 9. Two other Ipod Classics worked fine. I tried all the advice I could find on the internet, but nothing helped - that is until I stumbled over this advice.

I had an old Itunes 7 installation-file and installed it on a computer with no Itunes previously installed. I loaded a couple of mp3 files into Itunes and connected the Ipod. Itunes 7 recognized the Ipod immediately and syncronized it without any problems.

Then I moved the Ipod to the first computer with Itunes 9, and again it was recognized and synchronized.

I didn't even update the firmware (which is 1.3). I healed it simply by connecting it to an old version of Itunes.

Strange but true.
The Solution Master - Apr 13, 2010 at 06:25 PM
2
Thank you
RUN AWAY
1
Thank you
Did you try with an iTunes alternative such as this one http://www.copytrans.net/m
I tried it. Didn't work. Never recognizes the iPod. The only solution still seems to be the old-iTunes-version method.
1
Thank you
i have an 80gb classic too and nothing is making it work! :(
1
Thank you
ever since itunes 9.1 my ipod doesn't work either
0
Thank you
did you get it sorted, I have the same problem?