What's up with my Internet?!!?

[Closed]
Report
-
 Chelle -
Hey.
I've got a problem with my internet browser. I'm currently using Mozilla. The thing is, is that it won't let me play any games on it the other night. It played videos just fine but the darn thing wouldn't let me play games on the internet. Games like ones from Addictinggames.com and others. I was really angry and bored so I tried playing games from Neopets and it won't even let me play either. So I tried playing on Internet Explorer 7 but no avail. Any reason why? :(

2 replies


Dear Chelle,

The problem could be coming from the fact that you don't have the

latest Flash Player installed on your browser or still you should get

Java downloaded and installed. Please provide the details about the

game that you are unable to play so that we can help you about you

more accurately.

Thanks.
Ok.
Something else happenned. I went on google and tried googling the problem I had and clicked on this forum since it seemed familar. This guy told him to delete these files under... I'll just paste the link...
http://www.anetforums.com/posts.aspx?ThreadIndex=28770
It worked for the guy that had the problem. So that's what I tried. But NOOOOO! It made it even worse. I couldn't access my internet, pictures, files, and pretty much everything. I pressed the shutdown button and it didn't say logging off... and shutting down.. instead it was just a blank screen. So the next day I turned it back on and it said some stuff that I really couldn't remember(sorry). The part I do remember was that some boxes popped up and it failed to get my files back. So this other box showed up and I clicked System recovery, then it explained that by doing this it would erase all my stuff and return to factory mode. I had to choose whether or not I wanted to back my files up or not(I didn't). I had to wait a really long time for all those things to load and it restarted a bunch of times. So today I've spent my time getting my music, pictures, etc.
So then I tried playing games again but still didn't work. The games I tried playing were all from AddictingGames.com and eventually Neopets.com. All the games did not work for me. Although it was a bit different of what happenned last time. Last time when ever I started a game it would automatically say Not Responding and I would have to close my window.
Any ideas? So that I don't make the same mistake again?