Browser loading facebook pages in Mac OS [Solved/Closed]

AIESHA - Sep 30, 2008 at 02:10 PM - Latest reply:  MAjeed
- Dec 11, 2012 at 06:05 PM
Hello,

does anyone have a solution for this problem?

i use mac os cx 10.5.5

i am unable to open some pages of facebook and hotmail. Also I cant open some pages in flickr.
I tried deleting the history and cookies but still safari and firefox doesnt open the pages;. I tried enabling the developer and changing the agents.s that also doesnt work. I tried with Opera too. In that also these web pages doesnt seem to load. I checkd with my ISP. They said its not their problem. It must be a problem of the OS X I guss

is there anyone who can help me.
See more 

18 replies

Best answer
39
Thank you
I have a mac and a pc hooked up to a router. My PC was working, but my mac would not load certain sites. To fix the problem I changed the MTU on the router to 1400 and I also changed my Ethernet settings on my mac and pc to match. That took care of the problem. Good Luck!

Thank you, Quink 39

Something to say? Add comment

CCM has helped 1671 users this month

It work now!
You have to change MTU to 1400 !
That worked like a dream, changing the MTU.
Cheers mate!
whats an MTU?
SIMIA 1 Posts Sunday September 6, 2009Registration date September 7, 2009 Last seen - Sep 7, 2009 at 01:33 PM
14
Thank you
installed java update. Both Safari and Firefox stopped loading facebook page. Tried emptying caches, resetting, downloading new versions of both, downloaded new flash player, nothing helped.
I even tried https://www.facebook.com/ by adding an s after https. Nope, still wont open the page.
It loads my registration info to enter, then it never gets me to the main page.

I am running MacOsx 10.5.8
please help
Thanks!
sy5t3ml0rd-0n3 - Feb 8, 2009 at 02:39 AM
9
Thank you
Quink... I was having the same problem with the same setup (XP works on all sites, Mac doesn't work on many sites). Several posts in different sites pointed to cookie settings, etc... Nothing worked.
After reading your last post (some time ago) I modified the MTU of the Mac's ethernet card.
That did the trick. Thanks!
Hi there, could you tell me how you modified the MTU on an ethernet card please. I have not the faintest idea how to do it. Thank you
mahatma_dj > MTU ethernet - Apr 16, 2009 at 07:12 AM
see http://support.apple.com/kb/HT2532 This worked for me, changing MTU to 1400. I found it weird that this problem arose immediately with a new macbook, and apple support didn't know about the issue. But anyway, glad I found this solution.
This worked perfectly for me! Thanks so much!
3
Thank you
i wasnt able to load facebook or youtube videos for so long! but I changed the MTU settings to 1400 and it works like magic!!!

thankyou whoever it was who figured this out...God bless!!!!
grace rider - Mar 14, 2009 at 01:16 PM
1
Thank you
I was having a problem with facebook pages in all types of browsers. I solved the problem by changing my dns server. DHCP had automatically used my home router as the DNS server (note I have DNS enable on my home router). However when I configured my Network settings on my mac to use the DNS server IP provide by my ISP this immediately solved the problem of download facebook pages. The pages now look normal with all the images.
1
Thank you
Hi:

I tried that MTU thing....changed it to 1400 and then to 1300. Facebook still does not load which is frustrating. After 4 minutes or so I get a weird page asking me to sign up for Facebook. I believe this is the only site I am having a problem with on Safari 4.0.3.
1
Thank you
all I can say is I am having the same problem.

I DL'd Clam an anti-virus for mac, I know we are not supposed to get viruses on macs but I am just checking all avenues.

I have 4 users and 2 of us are both experiencing this problem.

I know I don't have an answer to your issue, but I just wanted to reassure you you are not the only one having this issue.
1
Thank you
Thank you,,,MTU
0
Thank you
The changing of the MTU to 1400 on the Mac worked like magic !!!
0
Thank you
Thanks for the MTU tip! I've been looking everywhere and after suggesting that you clear your cache, nobody has had any solution. Thanks much
0
Thank you
amen! it worked! changing the mtu to 1400. what a relief!
0
Thank you
I have this problem too! so annoying some days its fine others it wont even work, would be great for an answer too!