WD external hard drive wont work!

[Closed]
Report
-
 jdubb -
Hello,

so i bought a WD 1TB external hard drive and now my laptop wont recognize it. when i plug it in, the icon on My Computer shows that the data is there but when i double click on it, it says windows explorer wont open it. how can i fix this? i know nothing about comps so be easy. Thanks

4 replies

Posts
4233
Registration date
Thursday August 19, 2010
Status
Moderator
Last seen
August 3, 2016

Hello,

Check first if your external drive is detected by your BIOS.

If it is the case, try this:

Click on Start --> Run ---> type diskmgmt.msc and click on OK.

Right-click on WD Passport Drive --> Select "Change Drive Letter and Paths..." --->

Click on "Add" button ---> Select your drive letter and click on OK.

Note : If the drive letter is already assigned, then try changing the drive letter

by clicking on "Change" button instead of "Add" button in the above step.

If the solutions above does not work, think to change the cable of the drive.

Good Luck!
i tried changing the drive and said external error. anytime i try to do anything with the F: drive it doesnt respond. i unplugged the chord from the drive and plugged it back in. i opened the drive and the folders showed up from my WD harddrive. however when i clicked on them it wouldnt do anything and the window would say "not responding". like i said, i know nothing about computers so any help is appreciated. i dont want to reformat the drive if it can be fixed.
Posts
4233
Registration date
Thursday August 19, 2010
Status
Moderator
Last seen
August 3, 2016

Hello,

Try to replace your cord with another one and reconnect your drive to see if you'll have access to your folders!

Regards!
Posts
45
Registration date
Tuesday August 2, 2011
Status
Member
Last seen
September 5, 2011
7
If you have access to a secondary PC or laptop, try connecting your drive to it using a different USB cable. Also try unplugging your drive from the power outlet for a few seconds and then connecting it again.
changed the chord out but didnt work. when the autoplay comes up when i plug it in ill hit the open files and the files will show up in the My Passport drive (F:). but as soon as i try to open one it goes into "Not Responding". tried unplugging, different chords and different comps. it does the same thing to every other comp it tried. should i give up and try to reformat this thing or is there hope?!?! LOL