Can't access folders on my USB drive

sopa - Aug 29, 2011 at 07:32 PM
 Anonymous User - Aug 30, 2011 at 12:54 AM

I have a Iomega 2.0 USB External Hard drive (320 GB) which I bought last year. It was good until last week which I could not view certain folders on it. When I open it I can only view files but not the folders.

I have tried going to folder properties and checking the 'view hidden files and folders' but it does not work.

Any suggestions would be great as I have tonnes of personnel and work data residing in the folders. My Notebook is a HP Probook 4320s and am running on Windows 7.




1 response

Anonymous User
Aug 30, 2011 at 12:54 AM

Try this 1.

Check whether the files are not in hidden mode. Follow the following steps.

Step 1:

Click on the below link and download the file "AutorunExterminator"

Extract it --> Double-click on "AutorunExterminator" --> Plug your External

hard drive now.

This will remove the autorun.inf files from your External Hard Drive and also from

the drives.

Step 2:

Click on "Start" -->Run --> type cmd and click on OK.

Here I assume your External hard drive as G:

Enter this command.

attrib -h -r -s /s /d g:\*.*

You can copy the above command --> Right-click in the Command Prompt and

paste it.

Note : Replace the letter g with your External hard drive letter.

Now check for your files in External Drive.

Step 3:

After that, download the Malwarebytes' Anti-Malware from the below link

Update it --> Perform "Full Scan"

Note : Default selected option is "Quick Scan".

Good Luck.