[solved] Headphones not working with Windows [Solved/Closed]

markhelp 33 Posts Monday April 30, 2012Registration date May 13, 2012 Last seen - Apr 30, 2012 at 12:32 PM - Latest reply:  KingsHillSoftware
- Jul 30, 2017 at 11:45 AM
Hello,


This post is for people who are having a very specific issue.


Please see: http://ccm.net/faq/4462-no-sound-from-my-laptop-headphone-jack
Before you try this fix.

The issue this fix addresses was on an HP Compaq 515 running Windows 7 Home Premium.

Presentation:
-Computer is a laptop with working speakers
-When headphones are plugged in they are detected but do not play music
-You cannot set the headphones as the default playback device even if you disable the speakers
-Reinstalling the audio drivers does NOT work

Solution:
-Open "Add or Remove Programs"
-Uninstall IDT Audio
-Restart computer

If this solution doesn't work for you and you would like to undo it, please use System Restore

Hope this helps someone,

mark
See more 

25 replies

Best answer
35
Thank you
hi but there is only speaker and it is unable to touch default setting

Thank you, pooja 35

Something to say? Add comment

CCM has helped 1978 users this month

i had the same problem up until 2 minutes ago, my laptop is elitebook 8440p and I ended up fixing the issue through something called IDT HD Audio Driver after installing it , I had the headphone appear in devices besides speakers.

there was no default since there was only speakers ..
Thanks Reza - have the same laptop and this solved my problem also.
KingsHillSoftware - Jul 30, 2017 at 11:45 AM
Ah! Thank you! I didn't accidently remove this, the latest Windows 10 update did. I have an old 8460p which has been great, and this did the trick for me - I don't know how long it would have taken me to get to this, so thank you. This probably saved me a ton of time.

By the way, it may be the same driver, but I did go and search for that driver on my model, just in case.
30
Thank you
Hi try this out..

Speaker or headphone can be set as default.... [I'm nt sure if both can be activated in Win 7 at the same time ]

Control Panel -> Hardware & sounds -> Sound ->

In Playback tab Select Speaker / Headphone and click the drop-down Select Default.....

U can now enjoy hearing n headphone..
hope this helps...
Not sure how you figured that out, but at fist it did not work, so I kept switching back and forth on my default and *Somehow* It ended up figuring out it was there! You rock! Also, I'm using windows 8 if anyone else had the same frustration
Manoharan Thamizhan - Nov 21, 2014 at 08:44 AM
Superb...
I think it is the hardware problem.. and may too cost..
But now it is solved...
thanks a lot dear dude..
I am using Windows 8.1 and the only dropdown I see is Set default which is disabled.
Thanks so much it works
markhelp 33 Posts Monday April 30, 2012Registration date May 13, 2012 Last seen - Apr 30, 2012 at 12:45 PM
13
Thank you
To clarify:

This fix works because the computer will use audio drivers from the default Windows driver library. So after you do this fix you would expect for everything to work just fine.
markhelp 33 Posts Monday April 30, 2012Registration date May 13, 2012 Last seen - Apr 30, 2012 at 12:46 PM
10
Thank you
You could apply this method (basically of making Windows use default drivers) to similar audio issues, ie I have done this with a computer with Realtek audio as well (although the original problem was totally different)
4
Thank you
worked great!!! thanks
2
Thank you
worked great!!!