How to recover my pendrive data. [Solved/Closed]

GG - May 20, 2012 at 11:59 PM - Latest reply:  ritunjayb
- Aug 30, 2017 at 02:11 PM
Hello,

i have a problem in my pendrive. problem is that I dont know what type of threat came in pendrive. it hides all my folders pendrive. whenever I click on pendrive I cant see anything but when I see properties of that drive it shows data.how to remove this prob? ...wat type of virus is this dont have any name I tried all type of antivirus its scan in pen drive but I cant see them. plz help me if any body know this.
See more 

32 replies

Best answer
jack4rall 6507 Posts Sunday June 6, 2010Registration dateModeratorStatus December 30, 2015 Last seen - May 21, 2012 at 05:04 AM
23
Thank you
Hello,

Try this 1

Check whether the files are not in hidden mode. Follow the following steps.

Step 1:

Click on the below link and download the file "AutorunExterminator"

http://ccm.net/download/download-11613-autorun-exterminator

[Note : Make sure Dot Net Framework is installed in your PC to install the

"AutorunExterminator" OR

Click on the below link and download the Dot Net Framework

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=19]

Extract it --> Double-click on "AutorunExterminator" --> Plug your flash drive now.

This will remove the autorun.inf files from your flash drive and also from drives.

Step 2:

Click on "Start" --> In search bar, type cmd. Right-click on the command prompt

that appears in the search and select "Run as administrator".

"Command Prompt" will be opened.

Here I assume your flash drive as G:

Enter this command.

attrib -h -r -s /s /d g:\*.*

You can copy the above command --> Right-click in the Command Prompt and

paste it.

Note : Replace the letter g with your flash drive letter.

Now check for your files in Flash Drive.

Step 3:

After that, download the Malwarebytes' Anti-Malware from the below link

http://ccm.net/download/download-105-malwarebytes-anti-malware

Update it --> Perform "Full Scan"

Note : Default selected option is "Quick Scan".

Good Luck.

Thank you, jack4rall 23

Something to say? Add comment

CCM has helped 1669 users this month

Wow, thank you
Thanks its working
Simply running the command attrib -h -r -s /s /d g:\*.* did the job...my files in lost.dir folder are now accessible. Many thanks!!