Western digital 1TB external hard drive not recognized by PC

Solved/Closed
jazzed17
Posts
1
Registration date
Saturday March 9, 2013
Status
Member
Last seen
March 9, 2013
- Updated on Dec 21, 2018 at 04:13 AM
Hassan7411
Posts
1
Registration date
Wednesday February 27, 2019
Status
Member
Last seen
February 27, 2019
- Feb 27, 2019 at 02:19 AM
Hello,

I have a WD 1TB external hard drive, supposed new without documentation. The light comes on and there are soft noises from within, but when I connect to my laptop, the drive is not recognized.

There is no USB device acknowledgement of new device found. The drive does not show in the device manager or through My Computer.

I am running XP with SP3 on an older Dell Latitude D620. I saw an earlier response that involves modifying the registry, but I am very hesitant to do that because of past registry problems on a different PC.

I tried downloading a driver from WD, but it will not install. I tried that several more times with the same result. I changed the USB cable with no result.

It could be that I got suckered on buying a defective drive, but a quick check on Google shows this is a very common problem with WD external drives and there are hundreds of suggested fixes.

I am an average user with average technical skills, and this one has me stumped. Any suggestions will be greatly appreciated!

3 replies

Hi,
  • Click on Start --> Run ---> type diskmgmt.msc and click on OK
  • Right-click on WD Passport Drive --> Select Change Drive Letter and Paths...
  • Click on Add button ---> Select your drive letter and click on OK
  • Note: If the drive letter is already assigned, then try changing the drive letter by clicking on the Change button instead of Add button in the above step
  • If the problem still persists:
    • Click on Start --> Run --> type regedt32 and click on OK
    • Registry Editor will be opened
    • First backup your registry by going to File --> Export
    • Then expand the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E967- E325-11CE-BFC1-08002BE10318}
    • If you see any upper-filter or lowerf-ilters entries at the right side, simply delete them.
    • Close the registry and restart your PC.


Hope, it will work!
31
Thank you very much. Assigning the letter for the drive itself fixed for me.
0
Sorted.!! Good Tips my friend. It works 100% as good as before.
0
maybahag
Posts
1
Registration date
Tuesday October 28, 2014
Status
Member
Last seen
October 28, 2014

Oct 28, 2014 at 11:28 AM
Hi Diggi!
I tried the solution you suggested here. However, there's no "Change Drive Letter... nor "Add" upon right clicking.
Upon opening the diskmgmt.msc, a pop-up window says "You must initialize a disk before Logical Disk Mngt can access it"
And at the bottom, DISK 2 says, "unknown/ not initialized"
Although upon right click and properties, the name of the HDD (My Book) may be read...
Thanks in advance!
0
Thank you Bro it was helpful
0
MrDecember
Posts
1
Registration date
Sunday September 3, 2017
Status
Member
Last seen
September 3, 2017

Sep 3, 2017 at 12:00 PM
Thanks mate that was so helpful especially to an old novice.
0