Files on external drive changed to shortcuts

[Closed]
Report
Posts
1
Registration date
Monday March 18, 2013
Status
Member
Last seen
March 18, 2013
-
Posts
6428
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
July 16, 2020
-
Hello,

My external hard disk somehow not working. When i double click on external hard disk icon, it is taking to a window where shortcut is created of hard disk. But even after clicking on that shortcut, my files are not accessible.
I tried solution provided by you on this site as below,
"Extract it --> Double-click on "AutorunExterminator" --> Plug your External

hard drive now.

This will remove the autorun.inf files from your External hard drive and also from

the drives.

Step 2:

Click on "Start" -->Run --> type cmd and click on OK.

Here I assume your External hard drive as G:

Enter this command.

attrib -h -r -s /s /d g:\*.* " (Performed all the steps)

But still no luck.

If possible please help on this.


1 reply

Posts
6428
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
July 16, 2020

Hello,

Try this 1

1) Disable the "Autoplay" feature. Click on the below link "Disable Autoplay",

and download the file --> Double-click on it and follow the instructions.

Disable Autoplay

2) Disable the "Autorun.inf". Click on the below link and follow the instructions.

First backup your registry. Click on Start --> Run --> Type regedt32 and press

Enter. "Registry Editor" will be opened.

( If you are using Windows 7, Start --> In search bar--> Type regedt32 and press

Enter.)

Now backup your registry by going to "File --> Export" --> Save the file with any

name in your desired location.

Copy the text starting from "REGEDIT4" upto @="@SYS:DoesNotExist"

REGEDIT4     
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\IniFileMapping\Autorun.inf]     
@="@SYS:DoesNotExist"  

Open a "Notepad" --> Paste it --> Save the file as fix.reg

Note: Don't forget the extension "reg"

Now double-click on the fix.reg file and then click on "Yes" to merge it,

[Note : After following the above instructions, whenever you place any autoplay

CD\DVD all you have to do is go to "My Computer" --> Open the CD\DVD drive

--> You have to double-click on the setup file.]

3) Click on the below link and download the file "AutorunExterminator"

https://ccm.net/download/download-11613-autorun-exterminator

Extract it --> Double-click on "AutorunExterminator" --> Plug your External drive

now. This will remove the autorun.inf files from drives and and also from your

External drive.

[Note : Make sure Dot Net Framework is installed in your PC.

4) Download the Malwarebytes' Anti-Malware from the below link

https://ccm.net/download/download-105-malwarebytes

Update the " Malwarebytes' Anti-Malware"

Plug your External drive and then perform "Full Scan"

Good Luck