Toshiba Satellite Pro C850 touchpad not working [Solved/Closed]

Report
-
 Kimtechmobiles -
My toshiba satellite pro C850 touchpad is not working when u want to tap on it but the only the left and right clicks are working.please help!

3 replies

Posts
6508
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
July 16, 2020
2,405
Hello,

Try this 1

1) First make sure that the Touchpad is not locked. Hold the "Fn" key and then

press "F1" key.

[Note : A touchpad symbol should be there on the "F1" key or else look for the

symbol in the function keys and use that particular key with the combination Fn.]

2) Unplug the power cord --> Remove the battery --> Hold the power button for

60 seconds --> Connect the power supply then try to switch ON the laptop and

later put the battery back into the laptop.

Good Luck
37
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2825 users have said thank you to us this month

thank you, it was helpfull
Thank you very much. It's really helpful.
GREAT! I have an application in which I use ctrl-f5 a lot, probably hit FN-f5 accidently!
Didn't have to do the battery trick and all, just hit FN-f5 and it was back.
Unbelievable, but it works. TYVM.

100percnt perfect bigup bro

Indeed..Same problem on inherited Toshiba C850-BLU.
I followed your process step by step and it totally worked as long as you don't try to skip parts of the directions. If you want to make it work, do it exactly as the process Jack4all directs. Believe me, I tried to leave out a step and it didn't work.
Thank you so much. I thought the machine was needing junk pile if no on board mouse...but I re-read your directions and followed exactly the second time and it totally worked!!!!!. Now we have a working mouse pad on a 64bit laptop. T YVM!
Posts
1
Registration date
Sunday February 22, 2015
Status
Member
Last seen
February 22, 2015

Thanks, Solved