Change MAC admin password without the disk

Solved/Closed
Pranjal sharma - Updated on Nov 11, 2018 at 03:38 PM
 CraigT - Mar 19, 2018 at 03:57 PM
Hello,
i lost my disk and forgot the admin password so please can you tell me how to change admin password without the disk
Related:

5 replies

xpcman Posts 19532 Registration date Wednesday October 8, 2008 Status Contributor Last seen June 15, 2019 1,830
Updated on Nov 27, 2018 at 04:38 AM
You can try this:

But, it will create a new account and your old files will still not be accessible.

Creating a new Admin on Mac Os X: Here's how to reset your OS X password without an OS X CD.
The Working solution for me was to create a new admin. You can create new admin like this by deleting a specific file.

You need to enter terminal and create a new admin account:
  • 1. Reboot
  • 2. Hold apple key + s key down after you hear the chime. (command + s keys on newer Macs)
  • 3. When you get text prompt enter in these terminal commands to create a brand new admin account (hitting return after each line):
     mount -uw /      rm /var/db/.AppleSetupDone      shutdown -h now     
  • 4. After rebooting you should have a brand new admin account. When you login as the new admin you can simply delete the old one and your good to go again!


Apple stores wont reset it for you. Computer shops may charge you $50 to $200 trying to reinstall the Mac and failing at the end.
1821
Once I get to the command part every time I hit the enter bottom says file or command not found, or invalid should I include the star symbol every time? because I try without it and still not let me to continue seems that this instructions should me more in detail and even more since we enter a very detail portion of the operative system, I wish you could guide me more in detail in what to do to accomplish this administrator set up, thank you.
0
mediadude > Vince
May 3, 2009 at 12:37 PM
vince, I just went through the process after loading Leo over Jaguar. Never use passwords, but long ago I must have entered oned while installing Jaguar! Forgot it, naturally. I used the unix command lines just as published here without the star/asterisks. Worked fist time.

By now you've figured it out another way, but it's nice to see a post like this that is so helpful.
0
buzzy > Vince
Aug 19, 2009 at 06:31 AM
please post the answer to the guy who couldnt get the apple =s to work , want as much knowledge before I try it . thanks ,buzzy
0
angee59 > Vince
Jan 31, 2010 at 10:02 PM
Okay I am trying to reset my admin password and have instructions without a disk, however it says to reboot and then after you hear the chime hold apple+s down...the problem is I don't see an apple key. I tried with command key but I get nothing, somebody please help me, I am confused!
0
cautoner > angee59
Feb 12, 2010 at 08:58 AM
The "apple" button is the command button. All of the instructions you have are case sensitive and need to be written exactly the way you have them.
0