Facebook Home page won't load [Solved/Closed]

- - Latest reply:  Sandy - Dec 1, 2017 at 02:01 AM
I've seen other messags like mine, but I haven't been able to solve this problem...

I have a desktop Emachines computer, and I'm using Windows XP.

Yesterday, I was using Facebook, and it was working fine. I was checking messages on one page, and playing the "Pirates" app in another window... and it all just stopped working. So I exited everything, and tried to sign back in, but when I did, the home page wouldn't load. It sort of comes up. It says Facebook, and it has the links at the top that say "profile, friends,inbox," and it has the little notification thing at the bottom... The little red bubble says I have 5 notifications, but when I click it nothing happens. I CAN however, click the "profile" link and go to my profile wall. I can see everything there, but none of the links work. I can't remove posts or anything.

I signed onto my husband's facebook, and then my sister's, and the same exact problem happened. Home page won't load, links don't work.

Everything else on the internet is working fine. Yahoo, Aol, Myspace, Google... it's all working perfectly.

I have emptied my cookies, cache, temporary folders. I have restarted the computer. I have allowed add ons and pop ups. I have made sure Facebook is a "Trusted Site." I have run Avast virus scan and Malwarebytes' Anti Malware scan. They detected no problems. Following a suggestion on this site, I downloaded Opera at www.opera.com. No results. I emailed Facebook. No answer. I called my ISP. Their answer: Server must be down. The server is not down. My sister down the road is on Facebook right now. My firewall is not blocking Facebook.

I think it may be a virus, because all of the icons on my desktop all suddenly have blue backgrounds for no reason... but Avast and Malwarebytes are finding nothing, there's nothing suspicious in my list of programs... However, if I did pick up a virus, it came from Facebook, because I'd been mostly offline for a long time, except to check my Facebook messages and play the facebook apps.

If anyone can tell me how to fix this, I will really appreciate it. I've wasted 2 hours today changing settings and downloading "fixes" that do nothing.
See more 

15 replies

Best answer
approved by Jean-François Pillou on Nov 27, 2018
284
Thank you
Luckily, I'm a genius and have figured out how to resolve this.
  • Add an 's' after your http, thereby making it a secure site connection.


In other words your url should read: https://www.facebook.com/home.php?ref=home (instead of http://www.facebook.com )

Say "Thank you" 284

A few words of thanks would be greatly appreciated. Add comment

CCM 4525 users have said thank you to us this month

you really are a genius - fixed mine too. thank you
Thank you
Your a legend jeff
98
Thank you
I fixed mine by simply clearing all saved browsing data on my browser.
I use Chrome and to do this you go to options -> Personal Stuff -> Clear browsing data... and then select delete everything (apart from passwords).
Next time you load facebook up, it should ask you to sign in (not automatically) and then the home page should load up.
Hope this helps.
71
Thank you
Ok Yes, Putting https:// instead of http:// infront of the Address will work, But this will become annoying after a while as you will need to do that on every page you change too.

SOLUTION:
1) If you have Firefox, Go on http://www.mozilla-europe.org/en/firefox/
2) Download the Latest Browser, making sure you close all programs down first.

1) If you have Internet Explorer, Go on http://www.microsoft.com/windows/Internet-explorer/default.aspx
2) Download the Latest Browser, making sure you close all programs down first.

1) If you have a different Browser, then look for the website that you aquire the Browser from.
2) Download the Latest Browser, making sure you close all programs down first.

REASON: (Why does this work?)
The Reason why this should work is because your Browser may have became corrupted. Reinstalling will make sure your files are back to where they belong.

Enjoy Facebooking!

(Don't Forget to + me!)
Hi sam ive tried this and it still does not work. The s does work but does not enable chat I am sooooooooooooooooooooo frustrated wih this any help it really appreciated!
70
Thank you
here is how you fix it if clearing out cache and cookies don't work.

Go here and edit this file:

C:\WINDOWS\system32\drivers\etc\

open with notepad HOSTS

you will see in the file:

127.0.0.1 www.myspace.com
127.0.0.1 www.facebook.com

delete those entries and save file.

Works now!!

Make sure to run AntiVirus scan afterwards.

Best of Luck!

White BEE!!!
tq.. u steps really works
it works for me THX!!!
thnxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx you are the genuis ;)
22
Thank you
PROBLEM FOUND AND SOLVED!!!!

This is caused by trojan vundo and can be detected using anti malware.
The link to the anti malware is this http://www.malwarebytes.org/

Once you scanned, detected, and deleted the file. Everything works normal after restart.

Good luck.
Posts
11
Registration date
Monday January 19, 2009
Last seen
June 16, 2009
8
Thank you
hi,
try to do a system restore to solve your problem.
>accessories
>system tools
>system restore
if despite doing a system restore your problem is not solved, then it must be a problem on facebook itself.
I have the same blasted problem. It worked fine on my computer and it's being fixed right now. My husband's laptop uses the same Internet connection and Facebook has never worked properly for it. I tried a different browser, but IE and Firefox both do it. I tried clearing cookies, restarting, updating Java and other things, etc., but nothing works except adding s to http, but then I have to add the s to every page.

My husband's laptop has XP Professional installed, but it seems this is happening on all versions of Windows. Very annoying. I can't wait to get my computer back and use it then, but it really bugs that I can't fix this on my husband's laptop.
I like u
I posted my quastion 1 min after the guy at the top of the page and , ya, I posted this 5 mins after I posted my quastion. its about the dsi so yo wont care about it, un less you kid
-
hi there .. where can I find the accesories ..
in my situation I can come up to the website but when im about to log in it douesnt work ..



HELP ME
Posts
2
Registration date
Tuesday January 5, 2010
Last seen
January 6, 2010
7
Thank you
I'm running Windows XP. When I was using SKYPE earlier tonight, there was a yellow stripe down the middle of the video of the person I was talking to. In diagnosing, I found that I had to "disable" the DirectX Features for Direct 3D Acceleration and/or to "disable" the Direct 3D Acceleration. After doing that it worked ok on SKYPE; no yellow stripe.

BUT, just now, when I logged onto Facebook, I encountered the problem with Internet Explorer 7 (had 8 but went back to 7) that everyone has listed above (IE cannot open http://www.facebook.com/home.php).

I "enabled" the DirectX Features once again, and NO PROBLEM.

Go to START > RUN > Type in the box "dxdiag" > OK

Under DISPLAY tab - make sure the Direct X Features have Direct Draw Acceleration ENABLED (as well as the Direct 3D Acceleration ENABLED.

Fixed it for me.
4
Thank you
Hi,

I was experiencing THE SAME PROBLEM. Then I realized it was Mozilla firefox, my browser. So I switched back to Internet explorer and it works fine. Try it once I'm sure it'll be fine.
4
Thank you
Okay right, i've been having the exact same problem for over a week now and i've finally sorted it out. I was using Internet Explorer 8 but didn't presume it would be anything to do with that because I downloaded it over a month ago and everything had been working fine, until last week. Anyway, I found that deleting IE8 solved the problem straight away, to do this go to:
1.) start
2.) control panel
3.) uninstall a programme (which is on the left hand pane at the bottom)
4.) view installed programmes (which is on the left hand pane at the top)
5.) uninstall a programme (which is on the left hand pane at the top)
6.) find Interner Explorer 8 and click on it
7.) click uninstall (which is in a toolbar about a 6th of the way down the page)
8.) wait for the programme to uninstall, and then, if it doesn't automatically, restart your compurer/laptop

Hope this helped :)
2
Thank you
run a c drive search and type trojan (remove ALL files that come up) don't worry, system config. files won't come up


Then search facebook and remove all files

finally if you type ads and remove the file named Radds and fadds that will resolve the problem


You must do it in that order or the trojan will fix it's self

i reccomend clearing temp internet files and cookies after

it should work, I looked over the script for the trojan and it seems to work
Thank that help me so much and I followed step by step..I did have the Virus from face book (Trojan vundo) and 3 others I have been cleaning my computer for a week and this helped.I did remove the virus and Trojan's I used Malewarebytes and avg 9.0 .The Trojan tied into my firewall, and And I did go back to windows 7 .And I also went to Microsoft.com and used the virus scanner and it caught things that my spy ware and virus protection missed ....





Thank you
1
Thank you
I had the exact same problem, and adding the 'S' to make the page a secure page solved the problem. However, I still could not use chat and had other problems, it annoyed me so much that I had to fix it.

Mine is working now fine. I think there is an issue with Kerio Personal Firewall, and the newest version of JAVA. I have uninstalled KPF, and now I can access facebook as normal.

Hope this helps some of you if the problem is the same.
1
Thank you
i had this problem 2!!!
when I opened my page, it said, u have been updates in2 the latest firefox
then it worked!!!
0
Thank you
I had left a comment last week that my PC was doing the same thing. I was SO annoying to have to put that S after the HTTP everytime! Every page required me doing that then I had to accept a security setting etc... it was simply annoying so I stopped going on FB. ANYHOW.. Last night I downloaded GOOGLE CHROME (which is awesome... webpages run SO FAST) and now POOF my FB loads properly again! SOOOOOoo... download Google Chrome] and it should fix your problem.

GOOD LUCK!
I keep getting an "Internet Explorer cannot display the webpage" message. I've checked my advanced settings under internet options to no avail. Any recommendations?
0
Thank you
While the "S" on the http is a good temp fix I found the solution for me was to change some settings. I have vista but xp should be similar. Go to Tools/Internet options - Browsing history/ settings. Make iexplorer look for a new page everytime and you problem will go away. IEX is trying to ;load a cached version of the page which obviously isn't on facebook any more.....

Good Luck
0
Thank you
Thanks heaps dchoc - what you suggested has, so far, worked for me. I no longer need to keep putting the "s" to make the site secure.

I also updated to the latest firefox browser, did all the scans etc.. so I have no idea why I was having this problem in the first place.