My Passport 0740 isn't detecting/

[Closed]
Report
Posts
1
Registration date
Tuesday July 28, 2015
Status
Member
Last seen
July 28, 2015
-
Posts
3606
Registration date
Monday September 1, 2014
Status
Member
Last seen
February 20, 2017
-
I have a western digital My Passport 0740 hard drive. It's about 3 years old now and has been working fine until one day it just stopped. It's not recognised on My Computer but I followed some other instructions about going into Device Manager and looking to see if it is registering on there and it is. The popup says that it is working properly and I tried updating drivers but it says it is up today. I've tried a different cable and nothing.

I have about 1Tb of stuff on there so I'd really like to try and get the HD working if at all possible. Or is there a way to get the stuff off it. I'm slightly limited for computer space at the minute as I am using an Asus Transformer tablet which is running Windows 8 or 8.1. I can't remember.

1 reply

Posts
3606
Registration date
Monday September 1, 2014
Status
Member
Last seen
February 20, 2017
152
Hi Kferg,

I am sorry for any inconvenience caused by this issue. I would recommend you to check the drive on another PC. If there is no change, check if it is visible in Disk Management? Does it have a drive letter and a file format? If the drive does not appear, go back to Device Manager and uninstall the drive. Restart the PC and plug the My Passport back in. The OS should reinstall it. Are there any noises coming from the drive? Can you feel it spinning?

Hope this helps