Acer dvd/cd not there [Solved/Closed]

Ottawabill - Oct 17, 2008 at 09:37 AM - Latest reply:  Marion
- Sep 7, 2017 at 03:34 AM

I just bought an acer computer with vista self extracting files. set it up last night but it doesn't see the dvd/cdrom, no drive letter for it, and no cd devices shown in the device listing. I am new to vista and have no idea how to have it recognise this drive. It does see the usb and memory card drives, but nothing for the cd. The cd does work ie has power to it. Because I have no disk (self extract) I can't just re-install...

At a loss!!


See more 

30 replies

Best answer
Thank you
Hello, I have the same problem except my computer is about 6 months old. One day my DVD drive was recognized and now the computer can't find it. What did you end up doing to fix this?

Thank you, bill 132

Something to say? Add comment

CCM has helped 1296 users this month

hey I have same problems, ( on and off) but I cant find any filter only 4 folders 0000, 0001, 0002, and Properties that I cant open ...any ideas
thx in adv
Hi this fixed the problem for 24 hrs, but CD drive no longer works again? Any ideas?
It worked for me thanks,

You've saved my poor old acer to see another day.
xpcman 19369 Posts Wednesday October 8, 2008Registration dateContributorStatus October 15, 2018 Last seen - Oct 17, 2008 at 12:41 PM
Thank you
If it's new take it back and get another.

If that's not an option - open up the case and remove and reconnect the IDE cable to the DVD drive (with the power off). The IDE cable is big flat one.

It's either a dead DVD drive, a bad cable or motherboard problem with the IDE plug.
Thank you
I have Acer Aspire 7520, bought in 2007, worked like a dream then started acting wierd in Dec '09. Failing to boot, freezing part way thru POST, then when it did boot, DVD drive disappeared and re-appeared sporadically and other such annoyances. Followed ACER1's advice and it worked for one power on, then same problems returned. Went to local DIY store and found hardened plastic version of same screw following onantho's comment, and all seemd to be well. Until today. Now my laptop will not do ANYTHING while the DVD drive is installed. Acer have been less than useless, and I could probably buy a small island with the cash I have spent calling their tech (un)support(ive) team, so no green button, I do not have 'an' answer, I have THE answer:
Steer clear of Acer. Save up and buy something good.
Thank you
Right click My Computer or Computer and go to properties. Go to Device Manager or the equivalent of that. Find you Dvd/Cd Drive. Right click, and then scan for hardware changes. That should bring it up and this is very simple to do.

If no reinstall the driver, thats almost always a fix.
Thanks, it worked
Worked like a charm!!! Thanks :)
Thank you
my acer aspire 6930 dvd driver run only in cd-rom, dvd is not recognized
Thank you
i followed above deleted upper and lower filters made no difference :(
Thank you
Acer aspire model 50... DVD drive dissapears... SOLVED. It's actually a manufacturing problem. The dvd metal case atually touches the the interior metal case of the laptop causing a shortcircuit. Solution: Remove The DVD drive from its place by removing the screw of the drive from the back of laptop and then pull the drive gently out from the laptop case. At the end of DVD case you can see the metalic extension, with a little hole. Cover that entire area with something, I used a sticker, but let that hole free, so you can put the screw back in once you put the DVD drive back in to the laptop case. That's it. If your DVD drive has no other defects, it should work. It's a common problem to all Acer Aspire 5 series (5100, 5101, 5020, etc etc).
If that is the problem then there is also another step to follow. One would have to replace the original screw,which is made of metal, with a plastic or non-conducting screw because that same screw still touches both metals. Of course, before thinking it through, I tried it and that did not work. I still have the problem. Any other suggestions?
If that is the problem then there is also another step to follow. One would have to replace the original screw which is metal with a plastic or non-conducting screw because the screw still touches both metals. Of course, without thinking it through, I tried it and that did not work. I still have the problem. Any other suggestion?
Are you kidding man??
Didn't work for me either, insulating the hole plate and removing the metal mounting screw.
Thank you
After owning the machine for 2 years, the machine stopped recognizing the CD drive. Followed the advise on here and took the machine apart to find the ribbon cable came unplugged. Taking the machine apart isnt for the faint of heart, but after about an hour it's working again.
xpcman 19369 Posts Wednesday October 8, 2008Registration dateContributorStatus October 15, 2018 Last seen - Dec 5, 2008 at 12:19 PM
Thank you
Give Vista a chance
weekendcomputerhack - May 22, 2009 at 04:16 PM
Thank you

The problem isn't the drive, or a Sony big brother association to the RIAA, it has to do with the crappy software Acer includes and forces you to run on the laptop! I have fixed my laptop and hope this helps any of you out there!

I have had many and MULTIPLE issues with the Acer 5100.
Most of the issues related to crappy software from Acer and Vista updates making them crash. Like an update eliminating my laptop from recognizing and accessing my hard drive, and a computer is pretty hard to run when it doesn't have access to a boot drive!
My latest frustration occurred recently when I installed the latest Vista service pack. I started having multiple issues with both my hard drive recognition and also eht eData security suite pre installed on my Acer 5100.
I started having MULTIPLE like 8-10 error pop up windows for eData Security. So I decided to uninstall it since I was running a different program to protect my laptop.
Well then iTunes started acting weird, not recognizing CD's and also not playing song files.
So I then wiped my system clean of eData, rebooted, rechecked there were not references to eData in the Regedit trees, and did a hard shut down, and a clean power on.
I then reinstalled eData and now my system is working smoothly.

Hope this helps.