Cannot access shared folders remotely [Solved/Closed]

-
Hello,

I have a shared folder (e.g. MyFolder) on a Windows computer (e.g. MyPC) with share permission for 'Everyone' having full control and security permission for 'Users' and 'Administrator' of the computer (MyPC).

When I try to access the shared (MyFolder) from another computer I get the following message

\\MyPC\\MyFolder is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

Access denied

I wonder why I am not getting the login prompt for user name and password ???

When I type \\MyPC\c$ I get a the login prompt. but when I type \\MyPC\MyFolder I get the above mentioned error.

Please help.

Thanks and regards
maqs
See more 

10 replies

Best answer
85
Thank you
EDIT: Under Windows 10 do as follows :
  • Go to Control Panel / Network and Internet / Network and Sharing Center / advance sharing settings.
  • Go to Change sharing options for different network profiles, and click "down arrow" on Private. Hover to HomeGroup connections
  • Choose "Allow Windows to manage homegroup connections (recommended)".
  • Save modifications.


Under older Windows systems :
  • 1. Share folder : Make a new folder or use an existing one, anywhere. Right click this folder and choose properties > sharing. Do the thing. You might have to turn off simple file sharing.
  • 2. Set permissions : Right click shared folder > properties > security. Add the user who you want to have access (if you don't care, add 'everyone' with full permission).


If you want to permit only specified users aka not 'everyone' then you might have to add those user as local users accounts on the computer you'r shareing a folder. These accounts might need a password (depends on your share settings).

If you add new accounts to the sharing computer you might want to hide these from the Welcome Screen.

If this does not help: go to http://www.google.com (or your preferred search engine) and type in "sharing folders in windows" or any error message you'r facing.

Say "Thank you" 85

A few words of thanks would be greatly appreciated. Add comment

CCM has helped 2850 users this month

33
Thank you
The $ sign states that's it's an administrative share, and gives you access to the root of the drive. You cannot access the folder without the $. Unless you want to permit everyone access.
Uhm... no. The dollar sign ($) at the end of a windows share designates that it is "hidden", it does NOT mean that it is administrative. All of the default administrative shares have $ at the end (\\<mycomputer\c$ etc) because they are created automatically, and they microsoft wanted them to be hidden.

You can add a $ to the end of any share name and it will not show up in any browse window. IT managers use this trick all the time to create shared folders that they don't want to show up in normal searches, but still be shared if the user and/or system knows how to get to it.
Posts
404
Registration date
Saturday February 21, 2009
Last seen
November 12, 2010
16
Thank you
First ensure there is no firewall blocking (Antivirus firewall, Windows firewall, etc) on computers, after that have a look on these simple file sharing or share file with user/group permission in XP articles, maybe you did not configure file sharing correctly.
14
Thank you
An easy way to get around the issue of an XP client not promting for username and password when accessing a shared folder is to map the shared folder as a network drive. On the client machine (XP), you can create a batch file to run anytime you need to connect the folder. create a text file with these contents: net use J: "\\pathname\to\share" password /user:your_usere_name. save it as a .cmd file. you can also run the command prompt of course. on some routers especially if its crossing from wired LAN to wireless the friendly names don't map through. so you might have to use the ip address of the sharing computer instead of its name.
You do not necessarily need to map it as network drive:
NET USE "\\ComputerName\Share" /user:Domain\UserName (better not to put the password in clear).
If you are not prompted for a password when you access a share most probably:
1) There are credentials already cached for that resource (check on "User Accounts / Manage your Passwords")
2) There is already a connection remembered for that resource (you can list all of them with "NET USE" and then use the /DELETE switch to remove it.
12
Thank you
hey Meck@STL,

"The tweak is there, to click on 'don't require passwords' in that Win7 tool. "

is there a same tweak on windows xp computers? both my xp pro and xp home dun prompt for passwords when I connect to the folder on my server(xp pro with permissions for specific users set)

currently I can use my Macbook to select "Connect As" when I select the folder and enter the authentication. but the windows computers just prompt "Access Denied"

Thanks for all your support guys.

Cheers!
Evan
8
Thank you
Fix my issues:

The account on the computer I wanted to access had the the option user must change password on next logon(
control pannel / administration tools / local user and groups / user / select user )

Uncheck and check password never expire

Then it work.... I guess because I never went into the account, I never notice the password change
Posts
404
Registration date
Saturday February 21, 2009
Last seen
November 12, 2010
6
Thank you
If you have enabled folder sharing with user/groups permission on computerA and allow user Alice to access, Alice must log on to Windows XP by using username Alice and Alice’s password on computerB when she tries to access this computerA's folder from computerB.
5
Thank you
Hi

Check the permission both in security and sharing option.In both option, permission must be given to everyone.
4
Thank you
I read over all this and other sites and have finally fixed this problem. Its not the firewall. Its not the homegroup. Its not anything on your XP machine. And its certainly not all those people that ask for your Service Pack level and amount of memory.

Get to the Network and Sharing Center / Change Homegroup options / Change Advanced Settings

You should be on a "home network" if you are behind a your cable/dsl router and sharing with other PCs in the home.

You will need to turn off passwords for your home network, if you normally don't use them. If you want passwords, you'll set them in the share diag (see next para).

You will need to click on a folder from windows explorer and chose properties, then sharing, then advanced. I found my 'users' folder and everthing in it is shared by default. I turned off sharing on that folder and used one at a lower level and share it to 'everyone'.

Finally, here's what will make XP network with 7. You need to go to your adapter (wireless or wired). From Network and Sharing Center, click on 'Change adapter Settings' on the left margin. Next, right-click and choose properties for the adapter you use. Click the sharing tab at the top, and then select the check box starting with "Allow other network users..". I also deselected the second box. The second one if for someone like IBM or HP to remotely access your PC for troubleshooting.
2
Thank you
hey Meck@STL, I cant seem to find network and sharing centre... are you advising for windows xp fix?

is there something on the client or server that I can tweat such that windows will prompt me to authenticate instead of showing me access denied and no other manner to log on to the folder?

Cheers!
Evan
no, I understood the problem to be this;
Win7 can see/manipulate XP files via share, but XP cannot see files/login to Win7.

the Network Shares Center mentioned is new for Win7, not in Vista or XP

The tweak is there, to click on 'don't require passwords' in that Win7 tool.

If you have XP to XP, then passwords are set when you create a user account. XP Pro/Home handle authentication differently, but I have both types machines on my network and they all share just fine.

If you don't have the advanced sharing menus in XP, you need to disable simple file sharing. From a folder window, click tools, folder optiosn, view, scroll to bottom and deselect "use simple file sharing".