Can't view Linksys router web page WRT54G [Solved/Closed]

- - Latest reply:  Neil - Aug 25, 2010 at 10:30 PM
Hello,
I can surf the web with no probs at all, I have no probs with my internet at all. My network card is updated and I can't connect to the device web page (WRT54G). Well... sorta. I get the password log in username and pass. I type "admin" for both and get the page but its literally like 20% there. most of the links/buttons arnt even there. The page says it fully loaded and I can click some options but I have no idea what they are because there is no words loaded... Please help!
See more 

4/24 replies

0
Thank you
i have a lot of information on linksys routers,

First of all when you are connecting to the router make sure you are on a wired connection. You cannot connect wirelessly by default but you can make it so you can. also when you are trying to make a internet connection on a new computer do it manually because it can mess up your other computers internet. Do all of the stuff normally except the IP adddress. make sure IP addresses are different or else you have to connect one computer to the internet before you can use the others. I have to reset my linksys WRT54G every day. all I do is unplug it and plug it back in. it works fine. Next time I suggest a different brand because linksys is bad for WIRELESS.
-1
Thank you
Two things:

Frustrated- There is a good chance you have a router that is failing. To be sure, disconnect the internet side, disable any security software you have (even if it seems like it wouldn't interfere), and try again. If that works, re-enable until you find the culprit. If you have access to another computer- maybe you could take the router to the computer even- it would be useful in determining quickly whether you have a problem in your PC or your router. If it is the router, the problem is likely the firmware as you seem to have suspected. There is often a means of resetting the firmware back to the factory version by performing some ackward startup routine such as holding in the reset button then plugging in the power and waiting for the LAN lights to start blinking. (I just made that up, I doubt it's correct for your router.) If it's software, well, that's a whole other can of worms. Good luck!


Others- Thanks for the ideas. The issue I was having was with accessing the config pages from my terminal server only. It would prompt me to log in, but then only show me a blank white page. After finding this thread via Google search, I decided to add the local IP address of the router to the allowed sites under the Privacy tab of IE, as well as adding it as a Trusted Site on the Security tab. It then worked perfectly. :)
Thanks for the reply, I tried accessing the router from 2 diff computers, and nothing changed. One of them was a vista home without any anti-virus protection, and still nothing. I got in contact with a Linksys tech rep, and we went over a bunch of troubleshooting strategies but to no avail. Unfortunately, it seems to be a corrupt firmware issue. So it will need to be replaced. Linksys will do it for free if u haven't voided your warranty, and since I haven't done anything to the router aside from update the firmware a while back it should still be good. I hope this is some help to ppl in same predicament. Still not sure what corrupted the firmware though, since it was working perfectly earlier. Good luck.
-1
Thank you
FYI, I have formatted that computer twice. and it still did the same thing. :(
-1
Thank you
Bad net card probably.