Sony Vaio Wireless Adaptor switch problems

Closed
Joshua Navarro - Apr 21, 2010 at 11:31 AM
 None - Nov 17, 2016 at 06:05 PM
So yeah I'm having problems with my wireless adaptor switch. I don't know if an update screwes with my registry or when I accidently dropped from my hand. The thing is that the system says it works properly but thet damn thing won't turn on even when I flip the switch. I saw on another forum that there are certain keys you can check. I just don't know how to check for them. Any thoughts on this? Thank for your cooperation. I don't want to have to take it CompUSA since they charged me 80 bucks just for them to check whats wrong with it >< Ripoff artists.

3 replies

Type in " Device Manager " on start > Network Adapters > Right-click the device > Uninstall > Restart your Laptop.

Worked for me.



Enjoy!
2
Leandro Tanaka
May 6, 2010 at 02:15 AM
Hi, I'm having almost the same problem with my Sony Vaio F115. When I bought my Vaio came with Windows 7 Home Premium, then I formatted and installed Windows 7 Ultimate 64. Since then the SmartWi utility says that the wireless hardware switch is turned off but the switch and light is turned on. Also in device manager I have problem with three devices wich the drivers can't be recognized and installed. I've tried many drivers from Sony eSupport website however the problems can't be solved.

About the switch light is not turning on, you may try to reinstall the original drivers, I had this problem too and this step worked for me.

You can install the drivers through the Vaio Care Software or downloading from esupport.sony.com.

Please, if you find some solution in respect of the problem I mentioned above contact me by email or msn:

lndr.tnk@hotmail.com

Thanks in advance

Regards
0
What kind of Software do I have to download?
0
Leandro Tanaka
May 9, 2010 at 01:29 PM
Open SmartWi software, go to Recovery & Restore in the left side menu. Click on Install Applications and Driver, finally go to the drivers tab, select Wireless Lan Driver (Atheros) and click on Start button.
If this driver doesn't work, try to install another ones such as Wireless Lan Driver (Intel), Chipset Driver (Intel), and so forth.

hope this can help you solve the problem.
0
Joshua Navarro
May 11, 2010 at 07:11 PM
I'll give it a shot but if it doesn't work I'll buy a wireless adaptor card......Hope for the best!
0
I have Sony VAIO VPCCW25FG, which has manual wifi switch, it was giving problem once in a while, it suddenly goes off, n again have to switch on manually. But last time it didn't work, I could do nothing, tried to reboot n trouble shoot, but nothing worked. Finally I uninstalled the atheros Qualcomm n rebooted, it started working, may it will b of use to someone so I'm posting here.
0