Sony Vaio wireless switch problem [Solved/Closed]

-
Hello,
I just recently put a new power jack in my laptop.
Everything worked fine except for now my wireless does not work.
I have a Dell Latitude D620 laptop. I keep getting an error that says the radio is disabled.
I try to enable it and it does not save the setting. It reverts back to disabled.
The FN - F2 keys do not turn the wireless on. It does nothing.
The wireless switch on the side seems to be very loose and the LED does not light up.
I've went into the wireless utility to enable it and I still get the error that says it is disabled.
It is recognized in my device manager and it says it is working properly.

I'm game for taking the whole thing apart again....I just don't know what to do from this point.

Any guesses would be great.
I don't have the money to send it back to Dell and, of course, the warranty has expired.

Thanks,
Kimberly
System Configuration: Windows XP
Internet Explorer 7.0
See more 

20 replies

Best answer
approved by Jean-François Pillou on Nov 28, 2018
191
Thank you
For the Sony Vaio problems connecting to the wireless network look for the Sony utility "Vaio Smart Network" If you can get that to run and provide you with a little control panel with three icons for wireless, wired, and phone - you tick the checkbox on the wireless and your little LED for the wireless card will light up and you are back in business.

EDIT: Another workaround: https://ccm.net/forum/affich-356149-wireless-switch-not-working-sony-vaio#3

Say "Thank you" 191

Glad we were able to help! Love us? Write us a review! Rate CCM

CCM 4953 users have said thank you to us this month

Thanks dude..
This solved it. Thanks
worked! thanks!
184
Thank you
I had the same problem with a Sony Vaio. It seems one of the updates put entries in my registry to start a Vaio Lan Manager with Windows.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run

Check these keys to see if any kind of a 3rd party Lan Manager is running. If so, delete the entries and reboot.

Sorry about the lateness of my answer, but I just had the problem.

Good luck.
can you explain this in a way I can understand, I dont get what I have to do, can someone explain in steps
Could someone explain the whole keys thing to me as well please because I don't know how to do all of this. Also I do not have the icon with the two arrows either. I could really do with help please and thank you!
where can I find the hkey_localmachine???
Look for Regedit, run it. Then look through the HKEY_LOCAL_MACHINE folder for the other folders and follow it etc.

I wouldn't recommend playing around with your registry if you're not familiar with what you're doing tbh.
Aardvark67
Posts
1
Registration date
Tuesday April 2, 2013
Last seen
April 2, 2013
-
Thank You oh clevva one ... worked like a charm on dell pp39l .. happened after a bunch of win 7 updates
30
Thank you
There are many reasons a wireless radio will stop functioning. First and foremost check to ensure your wireless radio switch is turned "on"

If this is the case then ensure you have wireless network drivers installed. (right click my computer, properties, hardware, hardware manager, network adapters)

If it appears to be installed correctly, Try this, Start > Run > type in
services.msc
scroll down the list for "Wireless Zero Configuration" right click, check properties, in the startup ensure it says "automatic" then simply click on "start" Once it's started, right click on your wireless connection icon, select "view available wireless connections" (should still be blank) click on "change advanced settings" then "wireless network" tab and ensure the check box that says "Use windows to configure my wireless settings" is checked...
Apply and OK all and then refresh your wireless network list.

Hope this helps.
15
Thank you
if wifi switch is not working, just disable wifi control/wifi switch on bios to turn on always the wifi.
thanks, this works.
14
Thank you
I used FN - F2 to fix my sister's wireless problem.. It does work.. she is using windows 7... Turned out she had a software failure...
10
Thank you
I have a latitude z. The solution was -but simple- yet it took a long time to figure out.

There is a small switch that controls the wireless on the left hand side of the computer close to the screen. Battery life is improved if the wireless is turned off, but then the wireless doesn't work. Duh.
8
Thank you
I had the same problem with my new Sony Vaio - was working online with my laptop in my lap, got up to get a drink, and found myself logged off. Could not find the wireless switch. The trouble shooting guide does NOT tell you where Sony engineers decided to hide your switch. It is located two inches to the left of the audio jack in the front, under the keyboard. It has the word "wireless" next to the indicator light in the front but it doesn't tell you where the switch is located. A simple arrow pointing below would be a brilliant idea that Sony engineers could not produce in their brains. You have to look underneath the laptop, lift it up and then you'll see the switch. When you hold the laptop against your body, it's actually very easy to turn the switch off without knowing what happened and then you scratch your head because you lost the wireless connection. Another sloppy Sony design, that makes the customer feel stupid for not finding the switch.
omg u just saved my night. I know NOTHING about computers therefore didnt know what the hell they meant by using the hardware switch. I thought it was something in the computer I had to find. I was ready to pull out my hair not being able to find it in the computer somewhere. thank you thank you thank you!!! xoxoxoxo
8
Thank you
I have a Vaio 38E, after last windows update I had a problem with WIFI as follows:-

Switch was on, Light was off!!
Diagnosis = no problems yet still no internet...

Initial fix was to go into the sony vaio smart network and turn off the wifi then turn on again...
(either use wifi switch off then on, or double click the two arrows on bottom right of screen, then go into wifi/wireless LAN, then settings turn off apply, then on then apply).
this works but gets annoying as you have to do it everytime you shut laptop or turn off.....

Looked for hours searched all over the place, was getting really p**ed off... then I found it..... after looking at it at least 100 times previously....

There is a check box to start the Sony Vaio Smart Network on startup...
(in the same place I was using to turn off and on the wifi !!!! see above)

deselect this option... and hey presto it works..
If you need it it can still be found in the programme menu....

Much easier than deleting registry files.... and reinstalling wifi....

Hope this helps, :)
7
Thank you
I have an HP. click start, then programs, then network and internet.
click hp wireless assistant. click on properties. check box for independent controls for wireless devices and click apply. click turn on. This should turn on your wireless connection.
6
Thank you
Make sure your hardware switch is turned on. If that doesn't help, then here's something u can try.

Go to Device Manager and disable the wireless card and enable it again. That worked for me. :)
5
Thank you
I had the same problem with my dell laptop my wireless stopped working try this it worked for me.
No need to send your laptop back to dell company,if you Have a Ebay account copy and paste this link ----> D-Link DWL-G650 108mbps PCMCIA Wireless Network Card.
It's $19.00 brand new on Ebay insert the Dlink card into your dell laptop on the side set it and you will get wireless connection working,that is the only info I can give you good luck julie.
4
Thank you
Had same problem on wifes Sony Vaio since yesterday. Despite wireless being turned on --got message "not turned on" did a restore back to 3-25 (the last time windows did update) and works fine again.
4
Thank you
For those that have a problem with the switch turned on and NOT having the LED light on, as well, I found a solution from another forum. This site happens to be the first site when "GOOGLED" and I thought I'd put this here.

Just remember to reboot your Sony Vaio.

CREDITS GO TO JOHNWILL
@http://forums.techguy.org/networking/672759-sony-vaio-wireless-problems.html

Disable IPv6:
  • 1. Hold the Windows key and type R, enter
    ncpa.cpl
    (without the quotes) and press Enter
  • 2. Right click on each network connection and select "Properties"
  • 3. Remove the checkmark from the box next to "Internet Protocol Version 6 (TCP/IPv6)
  • 4. Click OK to exit the dialog
2
Thank you
hi my nane is rain try holding the fn key and press either f10 11 or 12 those are the keys to turn on the net work. it worked for me
2
Thank you
Anyone having issues with the wireless switch / button etc not enabling their wireless, first check that the device is not disabled in BIOS. To check this, press F10 (or whatever it says on the first boot up screen when you power on your laptop) to enter System (or Computer) Set Up. Navigating around there you'll find a section called devices or something like that. Make sure the wireless card is not set to disabled.

If the card is disabled in BIOS then no amount of jiggery-pokery in the registry etc will work!
1
Thank you
I dont who you guys are but thanks. Looked all over the Laptop 'Sony VAIO' could not see a switch. Then you suggested the side an there it was.

Thanks from the alnd down under
0
Thank you
My HP laptop wireless switch wasn't working, and eventually I got it working again by the following:

write down or back up all your BIOS settings
remove external power and battery
(most important!) remove BIOS backup battery (a small watch-type cell, mine is next to the hard drive)

after 30 seconds or so, replace all batteries and power up

BIOS will give you a error of some kind (Check-sum for example) when you boot,
go into BIOS setup and reenter your date and time and any other data. Mine only needs date and time
but in case yours is different, be sure to write down your settings beforehand.

That fixed my wireless switch problem.
0
Thank you
On a Dell Vostro Laptop there is a physical switch on the left hand side that can disable the wireless - make sure it is pushed forward.
0
Thank you
Thank you so much (not that any of you should be looking at this thread anymore) for over a month I thought I had a broken wireless switch, and have been using a wireless USB and unloading and reloading drivers, etc, etc. , but Kimberly here reminded me to try the FN - F2 key - duh.
0
Thank you
My husband manages to disable his wireless by pressing shift and F2 at the same time. The solution for him is to use the Windows key +F2. Hope this helps.