Acer touch pad & left click not working [Solved/Closed]

Ray - Dec 19, 2010 at 09:59 PM - Latest reply:  ola101
- Jan 19, 2018 at 05:07 PM
Hello,

I had the same problem. Fortunately mine is under warranty. However before I sent it in for service. I pounded on the left click button pretty firmly and it started working again.
Give it a try. Thanks.

See more 

25 replies

Best answer
33
Thank you
thank you so much I thought I was done with my computer but f7 and fn worked for me.

Thank you, sai 33

Something to say? Add comment

CCM has helped 1959 users this month

It worked for me too. thanks.
Worked for me too! Thanks.
It worked for me too thanks mate. :-)
Surprisingly pounding left click hard and long did worked!!!!
Thank you, May God bless your memory
9
Thank you
If by Touchpad you mean the Gemstone Blue Audio Controls on an Acer laptop then there is a fix which I was apprehensive about but it did do the trick.

Step1: Have laptop fully running

Step2: Remove Charger

Step3: Swiftly remove the battery from the laptop

Step4: Replace the battery

This should work 100%, it worked for me, I have an Acer Aspire 6920G Laptop
worked instantly. thanks
Thanks a lot for the tip!
This worked for me also! great recommendation. I have an Acer Aspire E 15 Touch.
I - as well - will thank you for the suggestion
thanks you
wludman 1 Posts Tuesday March 1, 2016Registration date March 1, 2016 Last seen - Mar 1, 2016 at 07:23 PM
0
Thank you
I have an Acer Aspire V3-731 laptop running Windows 8.1 64-bit.

Yesterday the left and right mouse button stopped working (i.e I'm not able to select Excel cells or buttons in other programs in the lower right hand corner of the screen (roughly 3"x3"). I first noticed the problem after I plugged into an HDMI cable to use the display of a large-screen tv for a presentation.

Can anyone suggest a fix?

Thanks,

Wayne Ludman
I have acer aspires 5732 z
Right n left click has stop, even cusser is not moving
Please, just go device manager and update the driver using existing software on your pc and use an older version of the driver. Afterwards you can change it back
Ridiculous, but pounding it actually just helped. New out of the box and mouse didn't work. Tapped it fiercely a few times and not working fine