Google Chrome loads very slow.

Solved/Closed
Julz_X - Mar 29, 2015 at 12:40 PM
 Blocked Profile - Jun 7, 2019 at 04:47 PM
Hi, I looked on other forums to see if other people had the same problems, but none of the solutions listed there worked.
My problem is:
When using google chrome, the loading thing first turns anticlockwise for ages, and then clockwise and the page loads. I have tried emptying cache, reinstalling twice and resetting. Nothing seems to work. It's not my internet connection because IE and Firefox work fine.
Here's my add-ons:
- Hola
- ABP
- Avast!

OS: Windows 10 T.P.
OS_2: Windows 7
RAM: 2GB
GPU: Nvidia GTX 750 Ti
CPU: 1,8 Ghz

Thanks,
Julz_X

2 replies

jack4rall Posts 6428 Registration date Sunday June 6, 2010 Status Moderator Last seen July 16, 2020
Updated on Mar 24, 2017 at 11:47 AM
Hello,

Try this 1.

1) Click on Start --> In search box, type
cmd
--> Then "CMD" will be displayed in the search --> Now right-click on "CMD" ---> Select "Run as administrator".

2) Now enter this command

netsh winsock reset
--> Press Enter.

Restart your PC.

Good Luck
196
Thanks! After restarting and clearing my cache I was good to go!
finally I can surf in speed!
0
thank you. this was a really great help. I tried so many things and only this worked. great. thanks.
0
Thanks, a fix that really worked.
0
mfd.texas Posts 1 Registration date Monday February 15, 2016 Status Member Last seen February 15, 2016
Feb 15, 2016 at 03:37 PM
Thank you so much for this fix. I have been chasing a slow sluggish Chrome browser and the "uncheck hardware acceleration" suggesting fix did nothing whatsoever. It been years since I've had to reset winsock.
0
It worked you are my hero
0
My Chrome was very slow to load and "netsh winsock reset --> Press Enter."
fixed it. Thanks. (I would have thought google would find an easier fix)
6