Unable to see External hard Drive?

Closed
Hydroxyphenyl - Apr 27, 2016 at 07:20 PM
 alysa iliana - Jun 23, 2016 at 08:56 AM
I have been using a 2-3tb seagate hard drive for a couple years now. Just today it decided to randomly stop working I guess. It used to be listed under E: on my computer, worked fine and I have 90% of what my computer is used for on it. without it I can't do much other than surf the web.

I have tried many solutions to this, including all the ones listed here:
http://ccm.net/forum/affich-522124-external-usb-hard-drive-don-t-show-up

But nothing seems to work.

Under computer management -- Storage-- Disk managment: It does not show up. Only C: and System Reserved. So I am not able to assign it back to E or F.

5 replies

Blocked Profile
Apr 27, 2016 at 07:22 PM
A Two year old 2 TB disk is used! you cannot rely on disks such as these as permanent solutions for storage. They are temporary storage. they are not designed to read/write as a normal hard drive.
0
Hydroxyphenyl
Apr 27, 2016 at 07:25 PM
Thanks for the comment. has absolutly nothing to do with a solution though. It can't go from working fine to just not showing up as an accessable drive for no reason.

IF you don't have advice on a possible fix/troubleshoot to see the problem please don't waste either of our time.
0
Blocked Profile
Apr 27, 2016 at 07:41 PM
Pardon me, I do this for a living, and I volunteer here. I am responsible for Petabytes of data (that is kilobyte, megabyte, gigabyte, terabyte, petabyte) in real time 24 hours a day 7 days a week. I am certain I know something about storage! Have a good day!
0
Hydroxyphenyl
Apr 27, 2016 at 07:50 PM
That is Amazing. But again, has nothing to do with this. It does not matter who you are or what you do when you come in and commont "It's used, it's not going to work forever". you're useless. I am asking for advice on a fix or way to troubleshoot it to find out why it is broken.

It is painfully obvious it is not a permanent thing, only an idiot would come in here thinking that kind of comment is useful. I am sure you know plenty about all this, but if you're not going to actually be helpful feel free not to comment any further.
0
Hydroxyphenyl
Apr 27, 2016 at 07:23 PM
So I have just found out under Disk management there is a Section called 'Disk 1' which is my hard drive. It is said as Unallocated and not initalized.

When I hit initialize disk it gives me the following options for partition style:

MBR (Master boot Record)
and
GPT (GUID partition table)

Selection either of these gives me an error saying "Data Error (cycilic Redudnacy check) the only option is to his OK and nothing happens.
0
Computertech
Posts
3569
Registration date
Friday February 6, 2015
Status
Moderator
Last seen
July 18, 2016
898
Apr 29, 2016 at 01:53 AM
Did you able run chkdsk for that drive in command prompt?

To do that run command prompt as administrator rights and type chkdsk d: /f d: is for your hard drive that has problem.

Please note that people answer here like ac3mark is a volunteer and me too to help people here atmost our best. Every comment posted by him or someother is to help you and advice you about the issue. if you post messages like "IF you don't have advice on a possible fix/troubleshoot to see the problem please don't waste either of our time." and "if you're not going to actually be helpful feel free not to comment any further." then you surely get no help at all. It looks like you hurting somebody who helping you.

Hope you understand.
0
Blocked Profile
Apr 27, 2016 at 07:51 PM
Portable HARD DRIVES FAIL! Are you prepared to take it apart and measure voltages, because that is next!
0
Blocked Profile
Apr 29, 2016 at 04:52 PM
I spoke with all of the hardware techs in my department today (9 of them are PC techs, 4 of them are server techs, and one of them is an APple geek). Everyone of them has never had a seagate last for over 12 months. That is a 100% failure of Seagate within 12 months.

Next time go for a western digital, or buffalo!

I have said it once, I will say it again. IT!
0

Didn't find the answer you are looking for?

Ask a question
More than likely the cause is that Windows renamed the drive to a letter that is already in use. This will happen if you have several card readers, thumb drives or external hard drives attached. It will also happen if you are on a network and have mapped drives. <REMOVED BY MODERATOR>
0