Windows 7 black screen with mOving cursor. [Solved/Closed]

- - Latest reply:  Helper - Apr 24, 2013 at 12:12 PM
I have an Dell up laptop and it's on windows 7. About a 4 days ago I was just browsing the web and my screen crashed. A window popes up and it seemed to be a windows 7 antivirus. It was scanning my computer and saying I had about 45 viruses. The window had the windows icon and everything but it was fishy. So I didn't click it. I restarted my laptop and it would load fine but the pop ups kept coming and I knew it was a virus. I went to a website called geekstogo and they usually help me with my malware/virus problems. Well I went through a couple steps and the pop ups stopped. So thinking it was gone I restarted the pc and then after the windows icon and t starts to load....it stays black and I can only see my cursor.

Here's my issue:
- can move cursor
-ctrl+alt+delete does not respond
-reboot to safemode, safemode command ended with same black screen

I can reboot and start CDs. I have tried putting in my windows 7 cd and repairing and no luck there either. After the repair it goes to black screen again.
I don't know if this is related to the virus or it was fixed but now something is just wrong with windows.

Help please!



See more 

2 replies

Best answer
Posts
4523
Registration date
Thursday August 19, 2010
Status
Moderator
Last seen
August 3, 2016
74
Thank you
Greetings,

Try this 1.

1) When you switch ON your computer, start tapping the "F8" key to get

"Windows Advanced Options"( if boot menu appears, press "Esc" key and keep

tapping the F8 key)

2) Select "Safe Mode with Networking"

3) Click on Start --> Run --> Type regedt32 and press Enter.

[ If you are using Windows Vista or 7 then click on Start --> In search box, type

regedt32 and press Enter.]

Registry Editor will be opened. Navigate to the following location

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

At the right side, find the strings shell & userinit and check the following

shell value data should be
Explorer.exe

userinit value data should be
C:\WINDOWS\system32\userinit.exe,

If shell and userinit are having different data values then change it as mentioned

above.

Just double click shell and userinit and enter the data values as

shell --> "Value data" should be
Explorer.exe

userinit --> "Value data" should be
C:\WINDOWS\system32\userinit.exe,

Note: there is "," at the end of userinit.exe

Then download "Malwarebytes' Anti-Malware" from the below link.

http://ccm.net/download/download-105-malwarebytes-anti-malware

Update it and perform "Full Scan"

Note : Default selected option is "Quick Scan"

Regards!

Say "Thank you" 74

A few words of thanks would be greatly appreciated. Add comment

CCM has helped 2750 users this month

Hello,

What did you mean by there are "," in userinit.exe?
he meant that the , must be included at the end
35
Thank you
I actually pressed f8 with my windows 7 cd inside and there are boot options from cd. I just clicked boot fro
Last good configuration and the screen came back.

thank you for your help :)