USB:\ is not accessible. Incorrect Function.

Closed
rickitikz Posts 1 Registration date Thursday January 24, 2013 Status Member Last seen January 24, 2013 - Jan 24, 2013 at 02:55 AM
 Amar Yadav - Nov 22, 2014 at 10:34 AM
Hello,

i've came to this problem, error message - usb:\ is not accessible. Incorrect Function. when I explore or open the drive.

my USB (Kingston 16GB - Data Traveler 101C) became inaccessible after having tried to repair and recover data using autorunExterminator (all files and folders on my usb became a shortcut icon), (kodus jack4rall thread)... the story goes this, im on the process of running the AutorunExterminator, seems working in perfect ways, it detected many Autorun.inf and counting and counting... I really could see the data retrieve using attrib -h -r -s /s /d g:\*.* ... to make the story short, I click the exit button of the AutorunExterminator, the program doesn't finished the process of accumulating Autorun.inf, I know I must let it done, but because I dont have much time staying at the office and catch home early(much important one), I decided to shut it down. On following morning, I continue repairing the usb and that's the error message i've got.

Is there anyway to recover my USB and the data in it? or there is another way to reformat the usb?

your help and advise are much appreciated..

thank you!

3 replies

If your drive is not infected with virus which is creating this problem then there is an utility that can help you make the drive working again. It is Active KillDisk. This is a free software that will help you to wipe out your Kingston drive easily in minutes. Download and install KillDisk, run the application. Make sure your pen drive is connected to the system. It will appear in the application. Remember that Killdisk detects all hard disks, floppy drives, USB drives connected to the computer at the moment. Hence select your drive properly and erase.
5
i cant see the pen drive and their graphical representation in disk management....
0
Zohaib R Posts 2368 Registration date Sunday September 23, 2012 Status Member Last seen December 13, 2018 69
Jan 24, 2013 at 07:11 AM
Hi rickitikz,

Let's try these simple steps and see if it works for your pen drive:

1. Try using this pen drive with another computer (a friend's computer or home computer).
2. If it works in another computer try to copy all the files from it and then format it.
3. If the pen drive is not detected in any computer, check in the Disk Management if it is detected. To check in disk management follow the below mentioned steps:

a. Right click "My Computer" icon on the desktop.
b. Select "Manage".
c. Click "Disk Management" from the right pane.
d. Check in the bottom of the window that opens. The size of all the disk drives and their graphical representations must be listed.
e. Check if your pen drive shows here.

4. Try to format the Pen Drive from here and see if you can.

Do reply with results.
-1
its not working in my case. its not showing my usb in manage
-1
Malik qasim ali
Jun 14, 2014 at 01:38 PM
i m also suffering such a problem bt I dont works. in disk managenet there is no memory shown ....
0
it worked for me brother,,,thanku
0
it's not working.......
0