Acer Aspire One ZG5 won't boot up [Solved/Closed]

- - Latest reply:  DULE - Mar 25, 2018 at 11:48 AM
Hello,
i bought this Acer ASpire One ZG5 in October 2008. Everything worked fine on it until last nite when I tried to start it up and I am only getting a blank screen...no sounds. what can I do to fix this? there are files on the system that I need to retrieve.
See more 

20/90 replies

2
Thank you
I tried to do this but still not working, does it mean a hardware failure already?
I don't think it's a total hardware failure.

There are different bios flash software there. Different ones for different issues. Try each one with the same step by step instructions. One of them should work. If not take the machine into a computer shop, if it's under a year old, it's still under warranty.
1
Thank you
THANK YOU VERY MUCH .. I SOLVED MY PROBLEM THANKS AGAIN......
1
Thank you
I had same issue few minutes ago followed the youtube procedure but also a battery drain as follow

Turn off computer and unplug power cord.


Disconnect all external devices.


Remove the battery.


Press power button and hold for 20 to 25 seconds and then release the power button.


Plug power cord back (please don't reinsert battery ) into computer and press power button.

also the instruction to download the files are here:

http://netbooks-us.custhelp.com/...
1
Thank you
first I tried it with my usb at least 10 times it didnt work I followed the steps exactly so I gave up.
then I tried changing my usb from the 2 gb to my old 256mb usb and it worked and it was up and running in under 2 mins :)
very happy
1
Thank you
Thank you, it worked with 3010 bios version on ACER Aspire one 150. Very helpful guide indeed!
1
Thank you
hey u just ur system restart n immediately press F8 function then u'll choose safely mode if it works then u'll see actually wat happened inside ur system otherwise after words i'll tell u wat u can do best of luck...
Posts
12176
Registration date
Wednesday November 28, 2007
Status
Moderator
Last seen
October 10, 2019
26
0
Thank you
Hi,

Try the safe mode : Booting Windows XP in Safe Mode then try to restore your computer. Choose a date when the problem didn't exist.

C u !
0
Thank you
Same problem here with me.
My Acer Aspire ZG5 stopped booting up since today morning.

THere is NO POST screen, nor bios, not the Acer logo
WHen I power it up, the power button gets lighted up.
Otherwise, the screen stays blank, black and dark.

THe HDD led shows no activity.

In short, the netbook does not respond nor give any message.

Can anyone please give us some solutions to work with please?
-
Yo Dude, I am sorry to hear about your laptop. Mine is doing the same but mine is a Acer Aspire 3050 No Acer logo. No Nothing. I just wanted to know if you Solved this problem. Because I was watching House on megavideo and I shut it down. next morning blank screen. was devestated. So if you have solved this problem I would love for you too guide me thru. Send me a e-mail back to last-three-letters@hotmail.com,
Thank you so much, Aaron Doyle.
> bringaaronthehorizon -
Same problem here with me.
My Acer Aspire ZG5 stopped booting up since yesterday morning.

THere is NO POST screen, nor bios, not the Acer logo
WHen I power it up, the power button gets lighted up.
Otherwise, the screen stays blank, black and dark.

THe HDD led shows no activity.

In short, the netbook does not respond nor give any message.

Can anyone please give us some solutions to work with please?
i have the same problem can u help me
can you please help me with instructions on doing this?
BAD HD try take it out and test it with enclosure. Otherwise BIOS crash, very rarely happens.
0
Thank you
im I the only person that this is not working for ahhhhhhh !
suecsuecsue
Posts
1
Registration date
Tuesday October 23, 2012
Status
Member
Last seen
October 23, 2012
-
nope. wont work for me. I've tried about a dozen times now... at least.
0
Thank you
Hello, I have same problem with Laxmin, have tried to use thumb flash, but it also didn't work.
Yeah, only the power button light up but the screen black and dark. Some machine sound from the pc.
Thanks heaps, It worked for me 1st time
0
Thank you
I had this same problem I tried to flash the bios this same way (FN + ESC) power on etc... didn't work until I removed the AC power, Battery and then also the CMOS battery (the button cell battery on the motherboard.) left for few hours then rebuilt the acer aspire one to flash the bios. it worked but as acer informed me after this VOIDS YOUR WARRANTY!!! so if its in warranty this will be best to send it to acer to sort out they usually replace your screen just incase it is faulty and they flash the bios. if you void your warranty (and they will find out if you flashed the bios or not) they charge you £51.99 just for them to book it in and tell you what is wrong with it and then you have to pay more if you want them to fix it!!!
0
Thank you
Thanks lot , solve problem
0
Thank you
Hi I have tried all that you mention but no joy. It seems my usb drive is not flashing at all. Could this be because I have formatted it on a mac machine?

Thank you in advance for your advice and help
0
Thank you
I did the following Bios update, seemed to work fine for a couple days, until again I drained the battery! would not charge it, or turn on with battery out and power supply plugged in.
I did find a solution that is frustrating to understand why its like this~!
Have to have the lid / screen closed on the laptop. plug in power supply, then unplug where the power cord connects into the power supply ( the 3 pin that plugs into the HIPRO block) and wiggle its around and plug and unplug untill you hear some sparking sounds! The battery light on the laptop should eventrually flash for a split second , and you hear a power surge sound from the laptop! Make sure to fully plug the power supply, open up lid and it will power up fine.
I have tryed an aftermarket power supply unit as well, and still didnt solve the problem.
I know this procedure is un-sound, but its the only way I can get to power up my unit with the power supply. Doesnt seem to be a BIOS problem, but an internal issue to sensing (seeing) the power supply, until it gets some sort of voltage surge.
It runs and powers up fine with just the battery all times, just when I want to plug in the power supply I have to run this procedure everytime. i've been doing it for over a month and im getting very tired or messing around with the power cord for like 5 min until I see the battery light flash and then I can turn on my computer.
Any ideas or do I need to call for warranty work, which I dont want to do since it will slow down my progress with my project.
Thanks for any advice other than flashing the Bios with 3309 which I already did!
0
Thank you
My son's aspire one series, model ZG5, has a black screen also. I do not know what to do. I need help to fix it. The green, power button light is on but there is NOTHING on the screen. I've tried pressing every (and I mean EVERY) button on the laptop, but no luck. Can ANYONE please help me step by step? I'd really appreciate it.
0
Thank you
I do have the same problem with BSOD on my Acer One zg5.

I performed the steps in these forum but still it didn't resolve my issue.

I'm using a Sandisk Cruzer 8GB thumb drive. I tried formatting it to FAT but it won't allow me. Instead I've only formatted it to FAT32.

My question is that, was it the reason why it did not resolve my problem with BSOD since I'm using a USB that is formatted as FAT32 and not FAT (as specifically instructed in here)?

Please advise. Thanks
0
Thank you
I had the same problem, one day, out of nowhere, "black screen". I followed the Youtube video instructions, except there was no 3309 Bios file listed for my A0A150. There was a 3310, which I guessed might be a newer version. I took a chance and downloaded it, and followed the same instructions givien for the 3309. Within one minute, the computer rebooted, and is working again! Whoever you are that made the Youtube video, we all owe you a world of thanks.
0
Thank you
Thank you so much for posting instructions & youtube videos. Mine didn't work the first time but success on the third try.

Saved me a bundle since mine's 15 days out of warranty.
0
Thank you
And ... do you have any suggestions in case the USB is not read?
0
Thank you
Try the same 2 to 3 times or with diffent usb drive if still its not working call acer voice support or go to fixmyacer.com and place order for depot service.