Acer Aspire One ZG5 won't boot up

 smcNon-Aspired -
i bought this Acer ASpire One ZG5 in October 2008. Everything worked fine on it until last nite when I tried to start it up and I am only getting a blank sounds. what can I do to fix this? there are files on the system that I need to retrieve.

90 replies

Just go to the acer website and d/load the bios update 3309, open the folder and copy two files to a formatted fat usb stick. Rename the file FLASHIT to FLASHIT.EXE and the second file 3309.fd(bios file) to ZG5IA32.FD rename them precisely like that, please check your spelling is correct. Insert the usb stick into the usb left hand side make sure the charger is plugged in . Hold down keys fn+esc and power up the laptop, when the power led begins to blink release the two buttons and press the power button just once, observe the usb stick flashing indicating it's flashing the bios, please note this can take a few attempts, I once struggled for a few hours until I finally tamed the beast :) be patient okay, I would like to point out if you wish to update within winxp use the same bios update 3309 , extract the zipped files to a formatted usb stick and rename the two files again but DO NOT REMOVE or interfere with the other files in the folder , with the laptop up and running open the folder and click on the Insysdeflash file only within the winflash file, this will flash your bios within windows and update it to the latest version, I read that flashing it when using the fn+esc keys merely restores the bios , I have tested this and mine updated to 3309 only when I flashed my bios within windows using the complete d/loaded bios update as mentioned . It will be worth reading the read me file to see what has changed in this bios version, I can tell you that for those out there that have password issues i.e. hdd set, the need to enter password with upper case is not a requirement more and there are a lot more fixes too, enjoy and I hope this bit of info was useful:)
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 2821 users have said thank you to us this month

ur the best. God bless
Thank you very much, man

Δούλεψε κανονικά αμέσως Greek
Format το usb με τις εντολές από αυτό το site και αντιγραφή των αρχείων από το Link του Rainbow
Ακολουθήστε τις οδηγίες και θα επανέλθει ο "άρρωστος" στην καλή του λειτουργία.
It's been about 10 years since I updated the BIOS on a ZG5 so was a bit rusty. This guide served as a useful reminder and was clear and concise. Thanks again!
> BobbyP
I'm still struggling with this update. Nothing happens, the power button keeps blinking. I have tried this several times with no luck. I have been very careful to rename the files and the steps and just no luck. Could there be something else? Thanks.
Check this out: THIS ONE REALLY WORKS!!!!

ISSUE : Aspire One powers on but the screen remains blank

When my Aspire One powers on, the screen remains blank. How can I fix this?

Updating the BIOS will require a USB flash drive to store the BIOS information on during the update. To perform the update to the BIOS:

1. Go here and download and extract the latest BIOS for the netbook.
2. Rename the BIOS file from 3310.fd to zg5ia32.fd.
3. Copy zg5ia32.fd and Flashit.exe to USB flash drive
4. Ensure that the AC adapter is plugged in.
5. Insert the USB flash drive into a USB port.
6. Press and Hold down the Fn and the Esc keys together and press the power button.
7. When the unit's power light comes on wait a few seconds and release the Fn and Esc keys.
8. After the keys have been released the power light will start to blink.
9. During the BIOS update process the display will be blank.
10. Let the unit run and after approximately 1 to 7 minutes, the unit should reboot and the BIOS will be updated.

If the unit fails to reboot, or the BIOS was not updated sucessfully, try the steps again.

Note: These instructions are only for the Acer Aspire One AOA-110 and the AOA-150 netbook series and should not be performed on any other model Acer Aspire One.
the best report... thanksss a lot...
It worked perfectly, it booted up in 1 min... Use the 3310.fd (zg5ia.fd) and Flashit files in the Dos_Flash sub folder and follow Louise's instructions....
Thank you!

Thank you a lot, louise! It worked perfectly at first try!!!

you are an absolute legend! if you were in australia id buy you a beer!!

Thanks Dear it's really works for me. I was to upset when last night I got this problem. I thought my netbook totaly gone. but after this solution now my pc running well.
Thanks again.
acctually I also had the same problem with my ZG5 30 minutes ago, than I follow kenneth advice to click at or paste this link to your url to download this file
there is the following instruction there
Create a recovery USB drive to update the Bios on the unit. The specific steps to perform this recovery with the USB drive are:

Download & Extract
Rename the Bios name from 3309.fd to zg5ia32.fd.
* after renaming this 3309.fd file I thought I should also edit batch command inside 3309.BAT
* so I did, it's not difficult just open 3309.BAT using notepad and edit *
* flashit 3309.fd /mc /all /dc ===> to ===> flashit zg5ia32.fd /mc /all /dc
* than I save this file under the same name (3309.BAT)
Copy zg5ia32.fd and Flashit.exe and (3309.BAT also) to USB flash drive.

Start the restoration process:
A. Plug the AC Adapter into the unit.
B. Insert the USB flash drive into a USB port.
C. Press and Hold down the Fn and the Esc keys together.
D. Keep these keys held down and press power.
E. When the unit's power light comes on release the Fn and Esc keys.
F. After the keys have been released the power light will start to blink.
G. Let the unit run and after approximately 1-7 minutes (by the fact in My case I Only need 10 second), the unit should reboot.
H. Video should now be restored.

tadaa.. my zg5 post like it used to be

thank you very much for the programmer, kenneth for this useful link and all of you,
many thanks this worked perfectly for me
Thank You, is working!!!, great solution
Thankyou it works for my if anyone needs the file its here they change it and it cost a lot to find it.
Worked like a charm
Awesome!!! Perfect !!! My mom is again happy!!! thank you very much !!!
I had hoped this would fix my customers problem. However, it does not apply to the Acer Aspire One Series Model ZG5. As a matter of fact, Acer has NO information available for the ZG5, AOA150. Not even a Users Guide.

Does anyone else have any suggestions?

Registration date
Friday February 12, 2010
Last seen
November 16, 2011

sir my laptop AcerAspire one zG5 won't boot up blank screen apears blank wot should I do.?
I have this model and the method described farther down by Dejas with the Youtube clip worked like a champ. Rebooted in about 1 minute eliminating the Black Screen o' Death.
I did this with a ZG5 and it worked first try adn rebooted back to xp that was installed with no issue. TNX!!!!
thanks bro! it really work for my aspire ZG5.tvm get latest version for your BIOS.
This worked like a charm

I hid mine in the dust for almost a year after looking for accurate information and support that I couldn't find, but this was a piece of cake. I am so thankful that now I can use my netbook like a netbook again.

- ShadowMKII -
This is the second time I got the Black Screen of Death. The instructions here didn't work for me, but this did:

The difference is essentially to rename the file 3309.fd to zg5ia32.fd and to NOT press the power button again after holding FN+ESC and pressing the power button once.
Hi I don't know who you are but thanks for your post it worked after all else failed even Acer were not helpful as the machine was bought in another country. Thanks again.
thanks for the Youtube link -- those instructions worked better for me than the ACER support page ones

for me the difference was from Youtube vid advising:

Release the power button
and continue holding
FN and ESC for about 5
seconds. nice to be rescued from TBSoD!

:-) doll
to the person with the youtube vid I have been working with computers now for over 10 years and couldnt get the bios to flash untill your vid so thank you u have saved my bacon
thanx Dejan this worked for me
I woke up to find my Aspire One not booting. Thanks for all the tips here, I managed to revive it with the USB flash to BIOS. Used the 3309 version and renamed to zg5ia32.fd and works perfectly. USB flash and reboot took under a minute.

Thanks once again.
If BIOS flash doesn`t help, probably the problem is not the BIOS. Try one of thies steps (info from aspire one service manual). I tried reseating memory module and it helped. I had to take my acer apart. Do it on your own risk.

1. Make sure that the internal display is selected. On this notebook model, switching between the internal display and the external display is done by pressing Fn+F5. Reference Product pages for specific model procedures.
2. Make sure the computer has power by checking at least one of the following occurs:
* Fans start up
* Status LEDs light up
3. Drain any stored power by removing the power cable and battery and holding down the power button for 10 seconds. Reconnect the power and reboot the computer.
4. Connect an external monitor to the computer and switch between the internal display and the external display is by pressing Fn+F5 (on this model).
5. Disconnect power and all external devices including port replicators or docking stations. Remove any memory cards and CD/DVD discs. Restart the computer.
If the computer boots correctly, add the devices one by one until the failure point is discovered.
6. Reseat the memory modules (RAM).
7. Remove the drives.

I hope this will help someone.

Frequently Asked Questions

AspireOneAOA110, AspireOneAOA150

Q: No Display / System will not POST Aspire One AOA.



Create a recovery USB drive to update the Bios on the unit. The specific steps to perform this recovery with the USB drive are:

Download & Extract
Rename the Bios name from 3309.fd to zg5ia32.fd.
Copy zg5ia32.fd and Flashit.exe to USB flash drive.
Start the restoration process:

A. Plug the AC Adapter into the unit.
B. Insert the USB flash drive into a USB port.
C. Press and Hold down the Fn and the Esc keys together.
D. Keep these keys held down and press power.
E. When the unit's power light comes on release the Fn and Esc keys.
F. After the keys have been released the power light will start to blink.
G. Let the unit run and after approximately 1-7 minutes, the unit should reboot.
H. Video should now be restored.
If these steps fail to resolve the no post, no video issue please contact Acer Technical Support.
This procedure expects the USB to be read, but there is a large amount of people that are asking for help because this method does not work. Step G will never start, as the USB is never read. The power button blink, fine, but nothing more.
By the way, the power button does not blink when you release the Fn+Esc buttons, but just after half a second after pressing the power button, and still having the Fn+Esc pressed.
This has been most helpful, I followed instructions and it worked in less than two minutes, many thanks, almost threw machine in bin.....
My acer aoa150 wont let me go to the user screen' just keeps start over and over...what can I do to fix this problem
hi just had the same problem , ive tried the suggested fix, but still no luck :( ...any ideas ?anyone lost without my acer !
You should do what Rainbow (top of blog advises) it worked for me!
Hi I have the exact same problem power light on and nothing else. can hear the CPU fan and HDD but the screen is blank no light from it. does this mean a new screen cannot get the bios to flash and make pc boot. it worked fine last night now though...!
Any chancw of some help?

Hi I had the same problem changed downloaded the bios chenged the file numbers all as described. But I have it sorted now... what was causing the problem for me was that I too was using a 8gb mem stick and wouldnt allow me to format it as fat.. windows will only allow you to format mem stick under 2 gb I had a smaller one just under 2gb put it in to format and yes it let me format as fat. done as described form the others and it rebooted first time. so has worked perfect since. hope this is some use as it tripped me up for a week or so...
i had the same problem, I used the f-12 ke to reselect the boot drive, save settings and rebooted. worked for me
Nowonmai ,
"7. Press the power button ONCE. During this time, it will now initiate the BIOS update, DO NOT INTERRUPT IT UNDER ANY CIRCUMSTANCES. "

During this process, is there something on the screen?


How long did it take to flash the Bios on your system?
Registration date
Friday May 29, 2009
Last seen
November 9, 2009

The screen is blank during this time. Mine took about 5 minutes total time. It can take a bit longer. Keep an eye on the thumbdrive, if it has a light on it, it will be blinking while it flashes the bios. Then the machine will reboot on its own.
Registration date
Friday May 29, 2009
Last seen
November 9, 2009

it is not blinking?
Registration date
Friday May 29, 2009
Last seen
November 9, 2009

Mine took about 7 minutes, and the only indication there was anything happening was the light flasing occasinally on the end of the flash drive.

There will be no hard drive sounds or screen flashes or anyting on the machine itself.

hi! I have the same problem too! I already downloaded the said bios but iam afraid I will choose the wrong bios for me. they have this warning:

Flashing the wrong BIOS can cause harm to the system. Acer recommends that you should only upgrade your firmware/drivers if you have been instructed to do so by an Acer Customer Care representative. By using these firmware/drivers you agree to accept the possibility of product failure.

so, for my ZG5 netbook.. what do you think is the right one?
Registration date
Friday May 29, 2009
Last seen
November 9, 2009

That is the standard warning. Each of those Bio versions on the Acer site address different issues. the 3309 is for the blank black screen, unresponsive machine.
My Acer Aspire One wont boot at all. I applied the instructions from Rainbow_Demon and it solved. Just did it once! machine is running fine now. Thanks, Rainbow_Demon.
YAEHHHHH!!!! Cheers worked first time.
Holy Crap!!! I put ours in the garbage bag yesterday and thought I'll try one more time. I found this site and low and behold I have a screen on my computer again! Thank you thank you thank you!!!! I'm still in shock that it works!!! Thank god I pulled it out of the garbage!
Guys, many thanks for the tips, it saves me a lot. My Acer One got BSOD just now and I followed your link. It works!!!. I got all my PhD thesis data in my laptop and I have no warranty since I bought it overseas. Thanks, God loves you ...

i have the sam problem my acer notebook not booting up. I have a lot of photos, I dont want to lose will I lose the all if I reboot and follow your instructions? its due to go back to acr for repair as its under 2 months old but they said I will lose everything once thy repair it.

thx Sweetz
DON'T send it in
follow the instructions here and you wont loose any of your photos or data on the computer
I don't think my keyboard is working as my flash drive didn't even flash. Please help, and have I voided my warranty my trying to do the bois? Thx
Hello community !
I have a ZG5 from one friend from Japan (so japanese Acer !, maybe it is important)
yesterday he had the famous blank screen, won´t boot)
I looked on internet a find your procedure. but still it does not work it is a A0A 150

we did
1- go to acer and download the BIOS 3310 version (the 3309 is not available anymore)
2. I format one USB 1Go stick with windows in FAT
3 we decompress the files 3310.fd and flashit.exe on the usb (only these 2 files on root of the usb)
4- we follow the procedure : press Fn+Esc + start button
5- the led power starts to blink and my USB led is blinking also (good sign)
6- after 5-7 minutes, the led power stops blinking and stays fixed green BUT the usb continues to blink, again, and again, for more than 30 minutes until we decided to stop
we did not interrup the flash while the led power was blinking

we tried to change the name of the 3310.fd file to ZG5IA32.FD
Same results, the procedure seams to works, but after the power led stops to blink, the usb continues to blink and no reboot

we tried to press ONCE the power button after start with Fn + ESC = same result

so my question is :
1- does someone succeed on ZG5 A0A 150 and frimware 3310?
2- do I have to fin on the net the 3309 firm? or 3310 is ok also for ZG5 AOA 150 ?

2- Why do we have to change mane, or even copy the flashit.exe program, because this flashit.exe is a DOS program. editing the 3310.BAT, it shows "flashit 3310.fd /all /dc" => then , for me, flashit is a program that run under DOS. is it a DOS program calling the flash 3310.fd so Why do we have to change the name ? or why do we have to copy the flash.exe which only work under DOS, and here the dos does not start.

Thanks for your help
OK this is solved...

I went out and buy a new 1gb usb pendrive because I was suspecting that my usb was not ok to do that.
If you use usb stick, please pay attention to what I say because some of you will have the same problem

in some usb pendrive, like "USB disk pro", when I plug it on my xp, It creates 2drives:

A: disk 3 1/2

A: is like a virtual floppy disk drive, where I find document respecting the pendrive (PDF, .EXE for security, ...)
E: is my pendrive 1Gb where I previously copy the *.fd and flashit.exe

Even if I format my pendrive (clic right, format, or manager...) I cannot remove, or format the A: I cannot delete it
so I was thinking maybe the ZG5 could not flash the bios because it did not access the correct drive (access on A: instead of E:)
So I went outside and buy the cheapest, no security, basic usb pendrive 1Gb (not more because of FAT)
I copy the files *.fd and flashit.exe (I tested it with either 3310.fd or zg5ia32.fd and it worked, which is for me logical because name should doen not matter in my opinion)

Then I did the procedure. I take few seconds for me, only less than 20 seconds and the PC rebooted !

The fact this it is not clear if I did flash the bios or not, because After restart, I open the bios, strike F2 and the version is still V3301 ! and not V3310 so I am not really sure I did a complete flash. but what is sure is the PC works now.
Regards to all
thanks u guys
all these really works
Thanks very much for all the information in this thread. The BIOS flash cured the problem on my just-out-of-warranty Acer Aspire One AOA150Bb. I followed the instructions carefully and it worked first try.

Thanks again
Michael V