No sound on Youtube Videos in any browser

Registration date
Friday October 4, 2013
Last seen
October 5, 2013
- Oct 4, 2013 at 11:42 AM
 Katrina - May 12, 2015 at 03:35 PM
Win 7, 64, Home, Adobe Flash Player ActiveX 11.8.800.175, Adobe Flash Player Plugin 11.8.800.168, Firefox 24.0 (IE 10, Maxthon 3)

This may have started when I updated Adobe Flash Player 11 ActiveX to 11.8.800.175 on 9/27. All youtube videos in all browsers play video fine but no audio. Some websites with embedded flash play audio, some do not -- none with embedded youtube flash play audio. No problems with the Volume Mixer. Have run FireFox in Safe Mode and same problem. Computer audio outside browsers works fine. VLC, Windows Media Player all work fine. Problem is only in the browsers. I have K-Lite pack installed. Everything has been working with no problems.

Would really appreciate some help here.

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32]

5 replies

Registration date
Friday October 4, 2013
Last seen
October 5, 2013
Oct 5, 2013 at 12:06 PM
Well I have solved the problem and do I feel pretty stupid. Although I must say that this is easy to miss. It appears that the latest Flash update leaves the Flash player with the volume slider turned all the way down. It is unmuted but you don't see the volume slider unless you hover over the mute icon. Once you turn it up it is set for the Flash player for all videos. It never ceases to amaze me the decisions that software developers make.
3 sharp smacks for that fool
Aaaargh! Simples! Thank you so much.I feel really stupid too! But hey! Felt like a genius when the music came soaring up! Thanks again.
Had same problem with my windows eight after installing a new flash player. So I Checked out the volume mixers and behold, on of them was muted. just click on the volume icon, then mixers and make sure all volumes are unmute.
OMG. Thanks for the "hover" tip. All other sound worked EXCEPT youtube. All better now. Much appreciated.
Thank you ! just tried the "Hover" over the muted sound icon on youtube and , all working now. (issue due to recent flash player update)
Honestly I had the same problem, I tried to update my flash player and nothing happened. So I finally went to shut down my computer and it said restart & update, I clicked that, kept my laptop plugged in and it restarted. Now it works just fine! Hope this helps someone!
Hi all,
I have been having this issue for months

I have just found the following codec which has fixed the sound playing in IE 11 for youtube videos

the codec is from divx and is called H.264

Running windows 8.1 with IE 11, all latest widows patches
I have tried every flash version and fix suggested on hundreds of sites of which none worked

installed this codec and all is fixed

hope this helps everyone else
please note you may also need to do the following:
go to internet explorer options:

Tools / Internet Options
click on the Advanced TAB
Scroll down to - Multi-media
Tick the box:

'Play sounds in webpages'
close IE and re-open
Your suggestion in IE11 to enable "sounds in webpage" cured my youtube sound issues, Thanks!
Nov 18, 2014 at 09:31 AM
Thanks murph
THANK YOU I didn't have the other problems but this helped me youre the best.
Registration date
Monday February 1, 2010
Last seen
September 1, 2021
Updated on Nov 30, 2018 at 04:05 PM

Take a look at this CCM How-to article, it just may be the solution you are looking for:

Good luck

Didn't find the answer you are looking for?

Ask a question
sharing a possible solution I found:
encountered audio problem for youtube nov-dec 2013

for W7 x32

on the lower right side of the task bar, right click on the volume icon, click

click on the Playback tab

check if the playback device is Default Communication Device or a Third Party
device (i have Digital Power Station as 3rd Party)

highlight the built-in sound device (i have IDT High Def Audio CODEC), click the "Set as Default" button....

check all volume sliders / controls just to see if they are set to mute, untick/uncheck if they are... adjust volume to desired level.

* I still wanted to use DPS so I just reenabled it..
* I used a suggested registry edit from another site
* I updated Flash Player
* either one or all of these might have something to do for the fix..

i hope this helps..
After months of banging my palm against my head in frustration, I finally found your post which saved the day-and relieved my self-inflicted headache! Thanks a million!
Followed your advice and discovered that my FireFox volume was muted. Ta Da! ;)
This is all it took: "on the lower right side of the task bar, right click on the volume icon, click Sounds" . Once I clicked on the volume icon (like I do all the time to adjust or mute the volume) I saw the word "mixer" at the bottom. Clicked on THAT and discovered everything was on except the sound for FireFox was muted. Un-muted it and now it works, No installing/uninstalling anything! Again, thanks a million!