Report

How to format a write protected USB flash disk [Solved/Closed]

Ask a question simbilajohn 1Posts Friday February 8, 2013Registration date February 8, 2013 Last seen - Last answered on Sep 7, 2017 at 06:05 AM by Mohammed Rafiq
Hello,

When I Format my USB any time messaging that "The disk is write protected"
I already complete your solution of this formula format
1. insert the pendrive
2. dont open or format it directly
3. right click on my computer and go to manage
4.in computer managment window click on disk managment option
5. right click on the removable disk (i,h....)
6. select format
But my USB is not Format. When Formatting is complete 100% again messaging that "The operation did not complete because the media is write protected". How can I format my USB please help me sir
Helpful
+432
plus moins
Hope this will help you...
for windows only
  • Click start
  • then run regedit
  • go to this directory
    HKEY_LOCAL_MACHINE\SYSTEM\Currentcontrolset\control\
    if you can't find StorageDevicePolicies under control folder then make some new one. Follow this steps:
  • step 1: go to this directory
    HKEY_LOCAL_MACHINE\SYSTEM\Currentcontrolset\control\
    again and right click control folder
  • step 2: select new, then click key and rename the new key #1 folder into StorageDevicePolicies
  • step 3: right click StorageDevicePolicies folder and select new DWORD(32-bit) Value for 32-bit Operating System and select new DWORD(64-bit) Value for 64-bit Operating System
  • step 4: rename dword newer folder into WriteProtect, then double click WriteProtect and change the value data into 0 with hexadecimal base, Then close regedit
  • step 5: open my computer and refresh it 5 times without do anything to your usb, and properly eject your flash drive
  • step 6: plug in your usb again into your computer and format it using exfat instead of fat32



Now, you can use your flash drive again....
Was this answer helpful?  
umerishtiaq 1Posts Wednesday May 24, 2017Registration date May 24, 2017 Last seen - May 24, 2017 at 07:45 AM
Perfect !
Reply
SK- Jul 30, 2017 at 12:12 PM
Thank You! Followed instructions and seems to have worked. (Some steps could be a little clearer for those not so computer literate)
Reply
Mohammed Rafiq- Sep 7, 2017 at 06:05 AM
Thank u very much ... It was very helpful for me as I was facing this problem since many days...
Reply
Helpful
+430
plus moins
There is 8 ways to remove write protection on USB flash drive
1- Scan your flash drive with updated antivirus
2- Unlock your memory card or flash drive "some flash drive have lock/unlock button .
3- Make sure the files you want to move a printable
4- Fix write protected problem by DOS commands as following :
- From Windows start menu click on RUN or you can show it by clicking " Windows symbol + R " from your keyboard then write CMD
- Write this cmd order " diskpart " Then windows open new windows press YES.
- Write this order " list disk " then click enter ,DOS will show the disk devices in your PC .
- Write " select disk 2 " then enter .Note select your flash drive or memory card disk label 1 or 2 .
- Write " attributes disk clear readonly " then enter .

5- Fix write protected memory card by modifying windows registry by doing the following :
- Open "RUN" as we mentioned before .Write "regedit" then press enter .Click yes to open windows registry editor .
- By clicking your mouse from the windows registry editor , try to reach this path "
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies "
- After you reach this path ,search about this registry key " WriteProtect" then click right click "modify" , you will find key value 1 replace it with zero value then click ok

6- Update your flash drive firmware " first get chip genius report then copy chip vendor and chip vendor model and search in google about your flash drive firmware .

7- Try other format programs like " Hp disk format tool " and HDD low level format
Helpful
+74
plus moins
Hello

here is the solution to remove write protection in pendrive. please do the following steps


start - run -regedit - HKEY_LOCAL_MACHINE\SYSTEM\Currentcontrolset\control\storatedevicepolicies


in right side you will be getting writeprotect option, just right click that and modify the value from 1 to 0
Rakib- Dec 17, 2013 at 08:55 AM
Plese help
mpho- Dec 17, 2013 at 11:20 AM
this thing is irritating
D7oom_Alahdal- Dec 22, 2013 at 03:24 PM
if u can't find "StoredDevicePolicies" then u have to create one by right clicking on "control" > new > key > name it as "StoredDevicePolicies" then u have to create " WriteProtect " by right click one "Stored Device Policies" > new > DWORD > name it as " WriteProtect "
joy- Dec 25, 2013 at 03:21 AM
it is not working pls help another option
Faisal- Feb 25, 2014 at 06:39 AM
thanx bro GDB
Helpful
+66
plus moins
1. open command prompt (cmd.exe)
2. type "diskpart"
3. type "list disk"
4. identify which one is your USB disk.

5. type "SELECT DISK n", where n is the number of your USB disk.
*** BE CAREFUL AT THIS PART. Selecting the wrong disk might delete your hard drives ****

6. type "clean", (you may need to repeat twice or thrice). If it doesn't work, don't proceed with the next instruction :-(
7. type "create partition primary"
8. type "select partition"
9. type "active"
10. type "format fs=ntfs"
rit- Jan 27, 2014 at 12:51 PM
my pen drive is not showing in list disk
Earl- Feb 3, 2014 at 01:45 AM
Try this > list volume instead of list disk
geazzle- Feb 11, 2014 at 05:30 AM
when I type diskpart they give me this message"DiskPart has encoutered an error:access is denied" please help me
Waqas Kanju- Mar 19, 2014 at 02:32 PM
Bro, not working any alternative
Bobfollower- Sep 22, 2016 at 09:41 AM
Thank you That worked
Helpful
+45
plus moins
I don't know what you mean by write protected "tab"

Are these instructions more specific ?

*1. Open Start Menu

*2. Run, type regedit and press Enter; this will open the registry editor

*3. Navigate to the following path:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies*

4. Double click the key WriteProtect in the right pane and set the value to 0 In the Value Data Box. Press OK

*5. Exit Registry

*6. Restart your computer and re-connect your USB pen drive on your computer.
Noor- Dec 16, 2013 at 02:46 PM
What I can do if there is no "StorageDevicePolicies" ;(!!!
deep- Dec 25, 2013 at 05:59 AM
sorry bro it's not working
rocel jean- Jan 6, 2014 at 07:36 AM
thank you..it worked..thanks a lot..
prabhjot- Jan 12, 2014 at 05:54 AM
thanks brother.. its working . :)
sammy- Jan 26, 2014 at 02:21 PM
Thanks, this work for me, I was able to reclaim my 250Gb usb drive back.
Helpful
+23
plus moins
Try this:

For USB drives:

1. Open Start -> Run...
2. type diskmgmt.msc and press enter
3. right click on the partitin you want to format (where the leter and size is)
4. select 'Delete Partition...' and confirm
5. right mose button in the same place and select 'Create partition'
6. select primary partition
6. select size, file forma, disk leter, label etc should be all right if you leave defaults.
7. click ok

This will recreat the partition and format it in proper way. Helped me and will help to most of you if you have problem with MBR.
tushh- Mar 22, 2014 at 06:05 AM
hey thanks it worked for me.
Helpful
+23
plus moins
I cant format my TDK 16GB, tried on the registry no go. When I tried the command the Flash will not show on list disk command, tried "list volume" command it sjows all the drives but when I select the right drive the error I get is "The Argument you specified for this command are not valid". How can I fix this! Pls help...
suresh- Oct 5, 2016 at 07:07 AM
I don't know what you mean by write protected "tab"

Are these instructions more specific ?
  • 1. Open Start Menu
  • 2. Run, type regedit and press Enter; this will open the registry editor
  • 3. Navigate to the following path:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies*

4. Double click the key WriteProtect in the right pane and set the value to 0 In the Value Data Box. Press OK
  • 5. Exit Registry
  • 6. Restart your computer and re-connect your USB pen drive on your computer.
Helpful
+19
plus moins
thanks it work
ansar- Oct 7, 2013 at 12:52 PM
cant see that StorageDevicePolicies*....pls help me
germanicevich 1Posts Tuesday December 17, 2013Registration date December 17, 2013 Last seen - Dec 17, 2013 at 06:26 PM
Muchas gracias! it worked like a charm, I had that pesky USB bothering me for a week.
Thanks again , you are the best.
Helpful
+13
plus moins
how to identify which is the pendrive.. it showing name like 'disk 1 and disk 0' with volumes which also not matching
RedJohn- Jan 3, 2014 at 11:00 AM
Disk 0 is Allways your operating system :D
Helpful
+12
plus moins
tnx really work it..your good
Helpful
+9
plus moins
THANKS
jaga- Aug 19, 2016 at 01:56 AM
really this works thanks a lot ......
Tama- Aug 29, 2016 at 06:26 AM
I have tried all the above methods but none of them is working. Mine is a Lexar 8GB Flash Drive
Helpful
+8
plus moins
Thanks.

It worked
Helpful
+4
plus moins
Download and install HDD Low Level Format Tool
|on first card choose your USB device
|Then go to LOW-LEVEL FORMAT and cilck on Format this device

hope it works for you.

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!