External USB Hard Drive don't show up [Solved/Closed]

-
Hello,

My External USB Hard Drive do not shop up in Win 7 64bit. The day before every thing was running fine.

By plugging it in, there is even no more that spacial plug in sound. But, if I plug or unplug my USB Mouse there is a Sound an my Mouse works fine!

I checked in Computer Management, Disk Management and Device Management, there is nothing showing up about my External HD!

I made several Reboots with the External Hard drive plugged an unplugged.

I try to make an update on the USB Driver but it confirms of already having the latest version installed.

Even when I try to plug my HD into the USB plug were my mouse was plugged in, nothing happend. When I plug back in my USB Mouse, the Mouse is working fine!

Same thing is happening for my USB Hub as for my 2 External Hard Drives.

The External Hard Drives are not working even without USB Hub, same for the USB Hub without external Hard Drives.

Please help!

System Configuration: Windows 7 / Firefox 3.6.13
See more 

10 replies

Best answer
Posts
6500
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
December 30, 2015
121
Thank you
Hello,

Click on Start. In search box, type
cmd
and press Enter. "Command Prompt" will be opened. Now enter the below mentioned commands:
  • set devmgr_show_nonpresent_devices=1
    and press Enter
  • cd \
    and press Enter
  • cd windows\system32
    and press Enter
  • start devmgmt.msc
    and press Enter


"Device Manager" window will be opened. Now in the device manager, click on View > Select Show hidden devices.

Expand all the nodes by clicking on + symbol. If you find any grey or UNKNOWN entries, right click on it and select Uninstall.

Restart your PC. Now try connecting your external drive.

Good Luck

Say "Thank you" 121

Glad we were able to help! Love us? Write us a review! Rate CCM

CCM has helped 2763 users this month

my hard disk show on devmgmt.msc but not show on diskmgmt.msc
please help me.
Thanks
Thanks so much
mitchj
Posts
1
Registration date
Thursday January 18, 2018
Last seen
January 18, 2018
-
Thanks heaps Mate!
Thank you Thank you Thank you!!!!!!!!!!!!!!!!!!!!!
99
Thank you
Hi everyone! I had a similar problem to what a bunch of people here said. I have Windows 7 and was using a Toshiba external hard drive.
So, the external hard drive made a sound when I connected it. BUT
* When I plugged it in to any of my USB ports, I got this standard message that the device wasn't recognized and it may be defective.
* It didn't show up on My Computer
* It didn't show up in Disk Management

I was pretty worried. Searched all over. Finally put together a couple solutions and solved it! Here's what I did:

* I went to the Device Manager (you can just search it on your computer and you should find it)
* From there, I went to/expanded Universal Serial Bus controllers.
* There's a whole list there of all different devices and stuff, but one of them there was titled "unrecognized device", or something like that. I opened that and went to the Drivers tab, and there, I uninstalled the driver. It gave me a warning before that I was deleting the device from my computer, so if you get that, don't worry, just do it.
(*After I uninstalled the driver, I then clicked the button to update drivers... but it said the computer already had the latest driver installed. That kind of confused me because I thought I just uninstalled it, but either way, maybe for you it doesn't update drivers automatically and you'll have to do it there. You need the latest driver for it to work. I guess for me that step was unnecessary.)
* My external hard drive now showed up on Disk Management!
* Now, from Disk Management, in the top section where it just says the list of your devices, I right clicked on the hard drive, and clicked on Change Drive Letter and Paths...
* From there, I clicked "Change". My device was under drive E:, and I changed it to F:, because I saw some people saying online that you have to change the drive there to another one and then it'll work. It did for me! My hard drive now showed up in My Computer.

Hope this works for you!
Posts
1
Registration date
Wednesday January 30, 2013
Last seen
January 30, 2013
91
Thank you
If you still can't find a solution, read on.......

I've read all the replies & tried all of the solutions. Thanks to all who posted but none of them worked.

Using a Seagate portable 320 GB external drive with Windows 7 x64.

I'll cut to the chase - PLUG THE HARD DRIVE IN VIA A PORT ON THE BACK OF THE PC.

No,I'm not kidding. If you have a laptop with Win 7, spend $15 on a powered usb hub ( still a good idea if you have a desktop)

From the Seagate Website:

""These Drives are powered by a USB Port.Some USB ports don't provide enough power to run the Drive. Use a USB port on the back of your PC. A powered USB Hub may also be helpful if your PC doesn't supply enough power"

Tested and re-tested; the hard drive appears when plugging into a USB port in the rear, but not on the front.

If when you plug a flashdrive into one of the front usb ports and you get a message about the Device not being able to run as fast as it's capable of then you're likely to get this issue at some point. If you go into Devices & Printers on Win 7, you'll see a yellow warning marker next to "UserName-PC". Right Click > trouble-shoot and windows will attempt to install generic usb device drivers & fail. I'm guessing this is part of the problem.

FYI, I'm using a r3 Fractal with 1000w PS - over twice the standard 450w -so it's not lacking power to run the usb ports.

I didn't (or don't) have an issue with my WD or Hitachi portable hard-drives, only with the 2 Seagate ones.

Hopefully this saves someone the time I spent banging my head against the wall on this one.
58
Thank you
Hi there, My drive used to show up on my computer but after a few months It stopped showing up on my computer and was showing up fine on my laptop.

I found a solution for my Hard Disk HP External Drive which was not showing up on Windows 7 64 Bit. All I did was went to control Panel and then Devices and Printers and I could see that my drive was showing there, but not coming up as a drive on my computer. So I went to the properties and > driver and uninstalled the driver and then went to Device Manager and select scan for Hard Ware Changes, and thats it, next time when Win 7 automatically installed the External HDD Drivers my drive started showing up again.
Posts
5
Registration date
Sunday January 23, 2011
Last seen
January 23, 2011
23
Thank you
Hi,
I have the same problem as you, my WD External Hard Drive, does not show up in My Computer, or is being read in the Device Management, but it does make the sound when you insert a USB, and shows in the list to Safely Remove Hardware.
It says that 'Wizard could not find a better match for your hardware than the hardware you currently have installed' when I update it. Even when I uninstalled it and restarted my computer, it says 'Found New Hardware' and 'New Hardware is installed and ready for use' it can't be found in My Computer.

It has been a while since it did not read on my computer XP.
I had tried to find the answer in other forums, but nothing had work for me. They said to click 'Start menu' then right-click on 'My Computer' click 'Manage...' It shows up 'Computer Management' click on 'Disk Management' but my USB does not show, only the computer system.

I have tried all of the answers 'jack4rall' had wrote, and thank you for those, but it still does not work for my hard drive.

If yours is working, could you please tell me how you fixed it?

Thanks.
GotRice
Posts
5
Registration date
Sunday January 23, 2011
Last seen
January 23, 2011
-
There doesn't seem to be anything wrong with the USB cable, because I recently brought one, and it still has the same problem, the light is still there, but the computer is still not indicating that the hard drive is there.
The autoplay, that the computer used to always do doesn't show anymore.
jack4rall
Posts
6500
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
December 30, 2015
-
Hello,
Try this 1
Hello,
Try this 1.
Click on start --> run --> type regedt32 and click on OK.
( If you are using windows vista or 7 then click on Start --> In search box, type regedt32 and press Enter)
First backup your registry by going to file --> export.
At the left side navigate to this location
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318}
If you see any upperfilter or lowerfilters at the right side delete it.
Good Luck
hello, I did this one too and this time smth actually happened, somehow it started installing it again but this time it couldnt install, even it was installed at first. im sick of it. im scared that my external hd is broken and has some reaaly important things for me. help!
vangeli
Posts
1
Registration date
Sunday January 20, 2013
Last seen
January 20, 2013
-
I can't delete the curent key????:Cannot delete{4D36E..........}.Error while deleting key?????
17
Thank you
jack4rall, thank you for your answer. But I did not helped me out.

Now I trayed to plug my External HD in an other Computer vith Win Vista, an the HD works. Than I plag it back in my Win7 Laptop an it is Working fine!
Dont ask my why, I have no idear how thi is possible.

But when I try to plug it via my USB Hub into win 7 than nothing happend...
Now I neet to get Working my USB Hub.
I trayed to use the USB Hub with an shoter Cable but makes no differnces.

What els can Ido?
(the USB Hub is powered with a second powerplug not usb powered)
jack4rall
Posts
6500
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
December 30, 2015
-
Hello,
Try this 1
Remove all external device from the USB Hub and also disconnect the USB Hub from the computer.
Click on Start --> In search box, type devmgmt.msc and press Enter.
"Device Management" will be opened. Expand "Universal Serial Bus controllers".
Right-click on "USB Root Hub" --> Properties --> Click on "Power Management" tab --> Uncheck
the check box "Allow the computer to turn off this device to save power". Repeat this process for
each USB Root Hub in the list. Now try to connect it. If it failed to detect it then in device manager --> Click on "Action" menu --> Scan for hardware changes
If the problem still exists then unplug the device, restart your PC --> wait for few minutes before you plug the USB device into the computer or hub.
Good Luck
Posts
4
Registration date
Thursday January 3, 2013
Last seen
January 20, 2013
16
Thank you
I again tried unplugging the drive from the hub, and plugging it directly into the port. After a few minutes, all 4 partitions showed up on the computer page, but with no data except taking up the next 4 available drive letters. When I went to 'disk management', the drive finally appeared, but the file system was listed as 'RAW', instead of 'NTFS'. Is there some way to change this?
14
Thank you
I have the same problem with a WD HD in windows 7 64-bit: A sound is made when I plug in the device, and I am able to eject it, but the drive does not show up in "My Computer".

It actually shows up, albeit with a delay of a minute or more. I don't know if it is because of some kind of indexing. Anyway, give it a shot and wait for a couple of minutes.

Hope this can serve as a (at least temporary) solution
11
Thank you
Hi Jack4all,

Thank you for your replay. I try what you said, but no reaction from the usb hub. I try the USB Hub to connect it to an older computer with windows XP, after plugging it in winXP intalled it automatically an ready to use, than I try to insert a woking USB key and suprise again it is not working. Same as on my win7 Laptop...
I guess there is a problem with the HUB?
Or you think I should uninstall Standard USB Hub in the device manager, and try again?

thanks
jack4rall
Posts
6500
Registration date
Sunday June 6, 2010
Status
Moderator
Last seen
December 30, 2015
-
Hello,
If you still having the problem, try this 1
Plug your USB hub -->Click on Start --> In search box type devmgmt.msc and
press "Enter" --> Expand "Universal Serial Bus controllers" --> Right-click on
"USB Mass Storage Device" ---> Click on "Uninstall"--> Remove your USB hub and and restart your PC. If the problem still exists then update your USB drivers.
If the problem still exists then check your USB Hub.
Good Luck
Posts
4
Registration date
Thursday January 3, 2013
Last seen
January 20, 2013
10
Thank you
I also have had similar problems with windoze 7 professional 64. I first noticed it with an 8GB thumb drive. The solution for that was to take it to a computer using windoze XP, and when it worked when plugged in, I copied all the files to another drive. When I returned home, I found the first drive still didn't display, but all files were successfully copied.

I have 2 Seagate Expansion drives. The first one is a 2TB drive I transferred to my windoze 7 computer after using it for over a year with windoze XP. It worked for almost a year with the new system. The second was a new 3TB drive. It worked for a month, and I got the error message. When I rebooted the computer, it took about 5 minutes for the partitions on the drive to display, but they were not accessible. I got real strange results when I tried a file restore. It said I had 13.5TB of data in a .5TB partition. A few days later, I got the same error message from the 2TB drive. Currently, neither of them will appear either on the computer page, or under device manager.
I have tried some solutions shown here, but they will not dhow up in device manager. IL tried switching to another USB hub, and then plugging them directly into a port, but it did not help. Notwithstanding the above, I still have 3 USB drives working, and I hope they continue to do so, while I backup all the data files on them.


I suspect the problem is due to windoze 7, since the problem showed up shortly after I installed the latest upgrade(or should that be downgrade) from microsloth.
I was on the Seagate website, and noted that sevetral people in the forums had reported similar problems while using windoze 7 64bit.
I had this problem today w/ a new update. I searched everywhere for a solution, and found nothing that worked. However I went back to simple solution, went into control panel, hardware, and right clicked the drive that wasn't showing up... it had been disabled "due to interference". I clicked on 'make changes' and then "enable" and everything is working again.