No sound from my laptop headphone jack [Solved/Closed]

 Anon128 -
i have sound coming out of my laptop speaker but no sound from my headphone jack

Can you help me ?

9 replies

I had a similar problem. First of all, ensure that your headphones are connected to the right jack plug (the green one).

Go to the control panel, then to hardware and sound, then sound. You should see something called manage audio devices. Plug in your headphones and see if they show up. select your headphones at the bottom it will say set as default, select this option.

If they don't, then either your drivers (these things will tell your computer what kind of hardware it has and how to use it) are missing or the the headphone jack itself has failed. Lets say it is in fact your drivers that are missing, then all you need to do is either use windows update(it will detect many of your missing drivers) or go to the manufacturers website and look for them there(usually they will have a tab somewhere on the home page that will say something about support or downloads). And also try different headphones, those could have messed up as well.

Now lets say that you do see the headphones show up as an audio device. Then all you need to do is set them as the default and that should fix your problem. Though I will say that I currently have a problem with switching between the two. Once I start a program such as media player, it will stick with the current default audio device.

I hope that helps you.
Thank you

A few words of thanks would be greatly appreciated. Add comment

CCM 3117 users have said thank you to us this month

Thank you very much. This helped me when I really needed it at work :-)
Thanks Dude
Thanks that was really helpful. Just needed to update the drivers
dude I know how to fix it I had this exact problem!!!
Go to Control Pannel
click on Hardware and Sound
click on Sound
then you devices should come up ; speakers, Digital Audio, and headphones
plug your headphones in
then select headphones
at the bottom it will say set as default
select that!!
then when you disconnect your headphones it automatically switches to the speakers and when you plug them back in it automatically will switch to headphones!!
there ya go man!!!
it took me like 2 hours to figure that out lol.. hope I was helpful
its works thanksss :)
wow thanks so much clifton that was so helpful thanks alot
thanksssssssssssssssssssss so muchhhhhhhhhhhhhhhhhh clifton
and what happens if there isnt the option of having the headphones?
Hi, Clifton, I dunno if you'll ever come back and read this thread. But I want to thank you. You solved my issue with my headphones. I did like you said, and after I tried shutting down my browser and starting it up again (I'd been listening to an online radio station and realised I needed to shut down my browser to see if your suggestion would work), it worked perfectly. I guess this is one of the good things about the Net - that people are willing to post on forums like this and help others out. Thanks to you and everybody who posted offering advice to the rest of us!
RealTek HD Sound Problem
This works for my 7540 Acer laptop w/ built in Speakers and SoundCard

a) The Laptop has 3 Ports on the side- Pink,Green,Black
  • Pink Port is LineIn for an external device player jack
  • Green Port is LineIn for the Microphone jack
  • Black Port is LineOut for Headset or External Speakers jack
  • Plug the Green jack on Headphone - into the Black Port on the laptop.

b) Go to Control Panel and open - RealTek HD Audio manager
  • On the top of Page are 3 Icons -
  • One Icon is labelled Speakers One is for Digital optics, one is for Mic,
  • The Speakers Icon is misleading as it is also for Headphones (LineOut)
  • Select Speaker Icon and make it Default. Also tick Full Range - Front LR
  • Ignore the 4 vertical Analog Icons on the right side.

You should now have Headphone sound if your volume is not Muted.

Hope this works for Y'all.
try right clicking the speaker icon and going to playback devices/ plug in headphones, write click the headphone icon go to test/ see if you here anything then set the headphones to default it worked for me.if that does not work try updating your audio driver/if that does not work try uninstalling your audio driver and installing a new one like realtec audio driver.
I tried that, went to "playback devices" and then did a test to see if I can hear anything coming from the headphones. I did hear the sound, and set the headphones to "default" but that still didnt fix the problem. The sound still comes from my speakers and not headphones. BTW everything was working properly for me until my laptop crashed just recently and I had to take it in to Staples where they restored it.
i tried the test thing and the test worked through the headphones but when I play anything eles it still only comes out the speakers
The application will not recognise the different output device until you restart the app. The different audio output device needs to be set as default (in Control panel Sounds) and then you need to restart the app. It should then automatically use the new default device.
I was also hoping that someone had written a utility to force this change, but I suspect it's application dependent.
Thankyou sooooooooooooooooo much. So simple!
whoever you are! thanks a lot.......
it was getting on my nerves , as there was no sound in headphone.....anyways thanks.

U R GOD! thanks for the help.

thank you iy acually worked wow!!!
Faced with the same problem I found resetting the default output from the Control Panel did the trick.
I been following the threads, but I am using Vista, can't find the Manage audio devices under Hardware and Sound in Control Panel, and I am experience same problem as others, can't detect audio jack or external speakers, still in the process of figuring out whether that's a simple setting problem or hardware problem. I did try roll back to many different version of old drivers and latest drivers, didn't solve my problem.
old drivers can make it worse. I also haev same problem, and only way seems to be alternating setting headphones and speakers as eh default.
Control panel>sounds will bring up teh wondow in Vista.
Then get teh appllcation in post below for a quick change option rather than opening control panel all the time
ok, I did find that place where the little GUI LED senses the jack is plugged in or not, apparently my LED doesn't light up when I plug in the audio jack. I assume it's the hardware problem with that audio panel pass through board, updating drivers didn't seem to help, and opening the laptop up there was no loose connection anywhere, will find out when my new panel board arrives next week.
hi Davidliuzhou, I think I have a similar problem... my pc have been opened up and since then I cant hear through my headphones unless I press them I bit down.... do you think it is loose connection or sth that has been cut up??
I followed those steps and it didn't work, but here's what did:

under Control Panel>System>Sound, Video & Game Controllers I uninstalled all devices listed, then restarted my laptop. Windows automatically found the speakers and reinstalled them. Then I plugged in the headphones & went back to Control Panel>Sound and set the headphones as the default device, then restarted again. Works perfectly now!
Dude u r awesome!! Worked perfect!!
Did what you said and solved the problem. Somehow the balance on the headphone jack had been moved all the way to the left channel. Fixed the problem in seconds, THANK YOU, saved me lots of messing around.