How to install apps on older iOS versions

How to install apps on older iOS versions

Apps update regularly and sometimes they require a recent version of the operating system. Downloading is then impossible for devices running on older versions of iOS. Fortunately, there is a solution. In this article, we will explain how to install applications when they require a more recent version of iOS, that you are unable to install.

How to download an app from the App Store?

When you try to download an application from the App Store, you will have already noticed this message indicating that it cannot be installed:

Sometimes, you may be offered to download an older compatible version for your device, but this is not always the case. Fortunately, there is another solution.

How to download an app from iTunes?

New versions of iTunes no longer allow you to download applications, as the App Store is no longer integrated. In this case, please download iTunes 12.6.4 from the following links:

iTunes for PC 32-bit - iTunes for PC 64-bit - iTunes for Mac OS

Open iTunes on your computer and search for the name of the application you want to download, via the search bar at the top right. For example, we will download the "Yahoo Mail" application:

Next, select the application you need in the search results of the App Store and click on Get. Log in to iTunes with your Apple ID and let the application be downloaded:

At the end of the download, open the App Store on your iOS device. Make sure you are logged in with the same Apple ID you used to log in to iTunes. Then go to the Updates category, and select Purchased. The "Yahoo Mail" application appears in the purchase list with a cloud-shaped button. Press on it:

A dialog box will appear asking you to download a previous version of the application. Confirm the download by pressing Download:

Finally, the installation starts:

Once the installation is completed, you can enjoy the application on your device. However, if the application requires hardware resources not available on the device (accelerometer, etc.) the application may not work.

Need more help with iOS? Check out our Forum!