Ask a question Report

Keyboard types numbers instead of letters [Solved/Closed]

Optimus2479 - Latest answer on Jan 9, 2013 07:41AM
Hello,
I have a HP Pavilion DV9000 entertainment PC.
When the num lock button is on certain keys on my keyboard types numbers instead of letters.
I have tried pressing the FN+num lock and FN+Shift+num lock and the problem still persists.
The letters that are typeing numbers with num lock on are U, I, O, P, J, K, L, and M.
Any help with this problem would be greatly appreciated.
Read more 
Answer
+321
moins plus
Try this.

Press the Start key + R.

type osk in that box and hit enter

On this keyboard, try toggling numlock scrolllock and capslock a few times. does it help?

I think your numlock might be stuck on and your keyboard "num lock" key isnt working

Liza0889- Dec 21, 2012 12:02PM
WOW your suggestion worked! thank you sooooo much!!
dsds- Dec 26, 2012 12:06PM
thanks alot. Two days since I had the problem. Thanks
asking- Jan 3, 2013 08:30PM
wait but how do i type "osk" if "o" and "k" appear as "6" and "2"
Charmaine- Jan 8, 2013 07:39AM
I type what I want in a word doc then copy and paste when it happens to me...but letters are only number when I type in a browser...
Raj- Jan 9, 2013 07:41AM
superb it works..
Answer
+131
moins plus
This is because of an external keyboard or screenkeyboard was used,
on that, numlock was changed, and still in the system.
When you unplug it, with the numlock off on the laptop, but on on the keyboard,
you will have a difference and its activated in the system, what only can be helped with an external keyboard possibly.
Sounds difficult, most because of my explaination, but here is to do it:

1: Turn off numlock on your laptop.
2: Plug in an external keyboard.
3: Probarely numlock is on, turn it off on the External,
but leave the laptop allone.
4: Now its both off,
5: unplug the Keyboard
6: Now it will be fine!

mark catapang- Dec 16, 2012 10:56AM
thank you it helps a lot!!!!
Vj- Dec 20, 2012 01:31AM
Thank you!!!
Answer
+43
moins plus
There is a FIX to this issue. Our laptop was having this issue after we unplugged an external keyboard. Hold the SHIFT & NUMLOCK keys on your laptop and it should fix the problem. It did ours.

PCguy- Feb 3, 2010 12:30PM
This worked on a Thinkpad.
mskpd- Mar 11, 2010 06:56AM
This works!!!! THANK YOU. But......here is the catch: you must first have number lock OFF. Type something to make sure your keyboard is all letters. Then.....if you need to use the numbers pad, hold shift while you do the number lock. Other sequences won't work.
DB- Apr 28, 2010 10:31AM
Thank you, DJ Daddi!

This works!!! I have been going crazy trying to fix it after I used an external keyboard. My only question is, should I continue to use an external keyboard when needed.

Thank you,
Answer
+26
moins plus
Try FN and Scroll. Hope it works for you. It did on mine.

Kuri- Jan 4, 2010 07:46PM
this worked on mine! fn and scroll! thanks a bunch!
Answer
+18
moins plus
This is normal - This is what NumLock does.

It types numbers for the letters - it's used on laptops that don't have room for a numeric key pad.

XMECH- Jan 25, 2010 06:54PM
No, xpc, I think u misdiagnosed it. I have the same problem and my keyboard has both number keys and
letter keys. My work 'puter has both also and NUMLOCK doesn't affect the problem. It just turns off the
numbers when not on.
supposedITprofessional- Feb 4, 2010 02:15AM
Turning off Numlock fixed my problem straight away. We didn't think of this as the 'problem' started at around the same time as me first installing an external keyboard.....Doh!
Answer
+14
moins plus
On my lap top i have a full qwerty key board. when i say letters being typed as numbers i mean the letters on my keyboard are being replaced by numbers. When numlock is on the numberpad should be the only thing that is typeing numbers when pressed. This is some kind of sticky key or something that effect that is on and I can not figure out to turn it off. This is not normal since it only just recently started doing this.

TnFatDaddy- Apr 19, 2010 08:42AM
I have a Lenovo 3000 N200 doing the same thing. The fix was hold the Fn key and then hit the ScnLk and then the NumLk then release the Fn key.
meee- May 8, 2010 09:38AM
hey thanks a lot ..yu really solved ma problem in a min which i tryin to solve from past 1 month....thanks a ton...
Ayaz- May 10, 2010 01:56AM
Thanks a lot.
REKU- Jun 27, 2010 12:53AM
THANKS A LOT THIS ONE WORKD FOR ME....
Answer
+6
moins plus
IT DOES HAVE ITS OWN NUMERIC KEYPAD JUST LIKE A REGULAR KEYBOARD, MINE DOES THE SAME THING; WHEN THE NUM LOCK BUTTON IS ON AND YOU USE THE REGULAR KEYBOARD TO THE LEFT TO TYPE YOU WILL INTERMITTANTLEY GET NUMBERS INSTEAD OF LETTERS WHILE TYPING

Answer
+5
moins plus
I have the same computer. What i do is to is i attach another external keyboard and use the numlock function on that. after that it seems to work, even when unplugged. But be warned, this seems to be only a temporary fix and i have to do this every time i restart.

Answer
+3
moins plus
Shift Number Lock worked on mine... thanks to earlier suggestion

Indre7777- Jan 18, 2010 09:36AM
i've got problam. I have laptop HP ze2000. Fn + j earlier worked as 1 (k as 2, l as 3, m as 0, etc.). Now it's gone. I can only write letters or if I want write numbers I must use english keyboard or turn on num lock/scroll lock but it's uncomfortable! Any ideas what's happened and how to get back back fn + letter to get number?
Answer
+3
moins plus
try to reistall your system drivers

Answer
+3
moins plus
c is 1 the d is 2 the e is 3 then f is 4 then g is 5 n carry on the pattern :P

Answer
+2
moins plus
I had the exact problem.
When typing the alphabet it'd be like a123423c6786868ef8908097342i64564jk96340357275824578265874pqr2576985702tuvwxyz
I closed every program ( because keyboard typing also did it :/ )
And the culprit was a program i was running because as soon as i closed it my typing worked

Answer
+2
moins plus
I have the same problem with the Number lock taking over the letters when I have a separate number pad like a standard full keyboard. I have a Toshiba Satellite P300D which had the keyboard replaced last year and ever since this has been happening. I seemed to have tried everthing, but has anyone got any other solutions?

Worzhak- Mar 14, 2010 11:29PM
I also have a Toshiba satalite P300 with the same problem and it started happening for me when they replaced the mother board.
Ben- Mar 20, 2010 04:27AM
I'm having the same problem with my toshiba satellite after i got the keyboard replaced.
WezzaBezza- Apr 3, 2010 08:50PM
though, they replaced something at mine too,
so they unplugged the keyboard i think and used
an external to fix stuff maybe.
But to fix, read my description below !
Answer
+2
moins plus
why can't write symbols like "i";"j" and others on right side ???

Answer
+2
moins plus
try shift numlk

Answer
+1
moins plus
thanks it was good for me , thanks again you are life safer

Answer
+1
moins plus
Answer
-1
moins plus
Many thanks to DJ Daddi, after trying different fixes, which were all unsuccessful, your trick worked first time and in seconds too, cheers mate.

This document entitled « Keyboard types numbers instead of letters » from CCM (ccm.net) is made available under the Creative Commons license. You can copy, modify copies of this page, under the conditions stipulated by the license, as this note appears clearly.

Not a member yet?

sign-up, it takes less than a minute and it's free!

Members get more answers than anonymous users.

Being a member gives you detailed monitoring of your requests.

Being a member gives you additional options.