Report

Keyboard mess up after shift key held too lon [Solved/Closed]

Ask a question barb - Last answered on Dec 20, 2012 at 04:29 AM
Hi< I guess I held down the shift key too long and even after rebooting and disconnecting my keyboard< I still cannot type certain characters and it won"t do caps unless I turn capslock OFF< and see< no commas or periods at all

can you help me?
See more 
Helpful
+1214
moins plus
I found that if you hold down both left and right shift key at the same time (did this for several seconds), it somehow solved the problem. Hopefully that fixed the issue. Also, go to control panel, click on accessibility options..in the keyboard tab, click on the settings buttons for sticky keys, filter keys and toggle keys and deselect the option to use shortcut..hopefully this will help you and other people that have had this problem.
debenski- Nov 11, 2012 at 12:47 PM
Can't believe that really worked! Thanks!
JackBauer- Nov 11, 2012 at 08:31 PM
AWESOME!!! Worked for me too!!! The double shift thing! I tried EVERYTHING too, thanks bud!
milinda- Nov 13, 2012 at 02:28 AM
Brilliant .thank you
RickyRyan- Nov 22, 2012 at 12:36 AM
Sure, but in 2012 it's "ease of access center", not "accessibility".
gar- Dec 20, 2012 at 04:29 AM
Thank youuu!! Very helpful
Helpful
+178
moins plus
Hold down both "Shift" keys at once, and hold "Alt" down at the same time....that's switching it back and forth between European and American keyboard. The way I can tell which mode my keyboard is in is the "=" in American it's an equal sign, and in European it's "ì". Another way to tell is the "#" sign. In American it's a number sign, in European it's the British pound sign ("£")..Hope this helps!











--------Gennie
rabbie boy- Jul 16, 2009 at 12:23 PM
Cheers ur a STAR it worked a treat
sushain- Oct 16, 2012 at 06:22 AM
i can't type two on and zero from the numbers on the right side and only five and six are working from the top numbers. also end key and page down keys are not working and i'm unable to type symbols from the top numbers using the shift key. please help.i 'm using windows seven on my laptop
willie- Oct 26, 2012 at 11:55 PM
That worked, thankyou.
Bob- Nov 2, 2012 at 04:37 PM
Nothing works for me!! :(
Bob- Nov 2, 2012 at 04:40 PM
I clicked something I think by accident and now all my keys are different . However I try it doesn't work I logged of and when I log on it is still not working now I cannot type my password and cannot get in! I can even put on screen keyboard! What to do?
Helpful
+41
moins plus
hello,

i dunno what have happen to my keyboard...
i cant use `SHIFT` to type symbols and stuff...
theres something wrong with the shift
Helpful
+38
moins plus
This is how to solve the toshiba keyboard problem É for question mark symbols and " for @ signs

hold the left ALT + SHIFT for 10 seconds

http://cyfocus.net
Helpful
+23
moins plus
my sony vaio cs had messed up two buttons...z and y. I solved the problem by holding both of shift buttons and CTRL. thanks for all advices on that website!!!
Helpful
+19
moins plus
The best advice for me was to hold both Shift keys together, followed by the Alt key. Everything else was useless. A BIG thanks to the person who suggested this. Muah!!!
Helpful
+18
moins plus
I pressed on fn + numlk and it worked for me, hope this helps.
Helpful
+14
moins plus
For windows 7, look up in the search bar "change how your keyboard works" I think it's in vista to I don't remember.. Then turn on sticky keys. I think if you press shift 5 times then it will turn them on or off.
Helpful
+12
moins plus
Thanks. My son messed up with my keyboard and your advice about holding both Shift keys at once worked.
Helpful
+8
moins plus
thank youuu :]
i held down shift to long, and holding them both down worked. :]
i was in the middle of some pretty important work,
so thankss :D
Helpful
+8
moins plus


You could press those 2 shift keys and hold. If it doesn't work you could press those 2 keys alternately. For example, 1st press left shift key then right shift key then left then right. Repeat that for 1 minute. That's all
Helpful
+7
moins plus
thank you soo much!!!!I had to post. The best advice was to hold down both shift keys at the same time. This was really pissing me off thanks again!!!!
Helpful
+7
moins plus
Fabulous! thanks that works!
Helpful
+7
moins plus
thank you soo much ..... holding both shift keys together solved my problem..... thanks for posting.......
Helpful
+6
moins plus
ok this is what happened... gy holding down the shift keys for more than 8 seconds it turns something on. I did this once on accident. you have to hold down both shift keys for a while and then check to see if its fixed. if it doesnt then try holding it down for a longer period of time. mine went within 2 minutes but some ppl waited for like 20 so give it a try.
Helpful
+6
moins plus
Thank you very much for posting your answer. I am in the middle of a time sensitive document, focused on what I was saying, left my finger on some key to long and BAM my keys gave different results. Google. Got this answer. Did the control menu sequence. Solved. Thanks.
Helpful
+6
moins plus
you could type the 2 shifts at the same time. One by one but fast
Helpful
+6
moins plus
Fantastic - both holding shifts solved the problem. Thanks for posting the answer :).
swaas- Aug 9, 2009 at 04:57 AM
that was the shits bit of andveive ever
Helpful
+5
moins plus
Many thanks, new it was software related when several keyboards behaved the same way (luckily I have spares).
Helpful
+5
moins plus
Gennie. Thanks very much. That solve the small problem I had. Handy to know
1 2 Next

Member requests are more likely to be responded to.

Members can monitor the statuses of their requests from their account pages.

A CCM membership gives you access to additional options.

Not a member yet?

Sign up now. It takes less than a minute and is completely free!