Keyboard mess up after shift key held too long [Solved/Closed]

barb - Sep 16, 2008 at 06:10 PM - Latest reply:  Smoke
- May 11, 2018 at 01:57 AM
Hi< I guess I held down the shift key too long and even after rebooting and disconnecting my keyboard< I still cannot type certain characters and it won"t do caps unless I turn capslock OFF< and see< no commas or periods at all

can you help me?
See more 

70 replies

Best answer
dragonaudra - Oct 8, 2008 at 08:37 PM
1283
Thank you
I found that if you hold down both left and right shift key at the same time (did this for several seconds), it somehow solved the problem. Hopefully that fixed the issue. Also, go to control panel, click on accessibility options..in the keyboard tab, click on the settings buttons for sticky keys, filter keys and toggle keys and deselect the option to use shortcut..hopefully this will help you and other people that have had this problem.

Thank you, dragonaudra 1283

Something to say? Add comment

CCM has helped 1974 users this month

Thank you! I didn't know what in the world I did.
It helped...sort of. I didn't know which key I held down too long, only that I had. I held both shift keys down for awhile, as recommended, and nothing. Since everyone was talking about it being a shift key, I then held down only the left shift key for awhile...nada. Then I held down only the right shift key for awhile and, voila, the keyboard was working again :-) Thank you, thank you.
Thank you.Very useful information
Thank you! Helpful for me.
186
Thank you
Hold down both "Shift" keys at once, and hold "Alt" down at the same time....that's switching it back and forth between European and American keyboard. The way I can tell which mode my keyboard is in is the "=" in American it's an equal sign, and in European it's "ì". Another way to tell is the "#" sign. In American it's a number sign, in European it's the British pound sign ("£")..Hope this helps!
--Gennie
Cheers ur a STAR it worked a treat
i can't type two on and zero from the numbers on the right side and only five and six are working from the top numbers. also end key and page down keys are not working and i'm unable to type symbols from the top numbers using the shift key. please help.i 'm using windows seven on my laptop
That worked, thankyou.
Nothing works for me!! :(
I clicked something I think by accident and now all my keys are different . However I try it doesn't work I logged of and when I log on it is still not working now I cannot type my password and cannot get in! I can even put on screen keyboard! What to do?
42
Thank you
This is how to solve the toshiba keyboard problem É for question mark symbols and " for @ signs

hold the left ALT + SHIFT for 10 seconds

http://cyfocus.net
37
Thank you
hello,

i dunno what have happen to my keyboard...
i cant use `SHIFT` to type symbols and stuff...
theres something wrong with the shift
22
Thank you
my sony vaio cs had messed up two buttons...z and y. I solved the problem by holding both of shift buttons and CTRL. thanks for all advices on that website!!!
22
Thank you
I pressed on fn + numlk and it worked for me, hope this helps.
21
Thank you
The best advice for me was to hold both Shift keys together, followed by the Alt key. Everything else was useless. A BIG thanks to the person who suggested this. Muah!!!
14
Thank you
For windows 7, look up in the search bar "change how your keyboard works" I think it's in vista to I don't remember.. Then turn on sticky keys. I think if you press shift 5 times then it will turn them on or off.
11
Thank you
Thanks. My son messed up with my keyboard and your advice about holding both Shift keys at once worked.
10
Thank you


You could press those 2 shift keys and hold. If it doesn't work you could press those 2 keys alternately. For example, 1st press left shift key then right shift key then left then right. Repeat that for 1 minute. That's all
dallasdamage - Jan 13, 2009 at 10:14 PM
7
Thank you
thank youuu :]
i held down shift to long, and holding them both down worked. :]
i was in the middle of some pretty important work,
so thankss :D
7
Thank you
thank you soo much!!!!I had to post. The best advice was to hold down both shift keys at the same time. This was really pissing me off thanks again!!!!
7
Thank you
thank you soo much ..... holding both shift keys together solved my problem..... thanks for posting.......
6
Thank you
Fabulous! thanks that works!
5
Thank you
ok this is what happened... gy holding down the shift keys for more than 8 seconds it turns something on. I did this once on accident. you have to hold down both shift keys for a while and then check to see if its fixed. if it doesnt then try holding it down for a longer period of time. mine went within 2 minutes but some ppl waited for like 20 so give it a try.
5
Thank you
Thank you very much for posting your answer. I am in the middle of a time sensitive document, focused on what I was saying, left my finger on some key to long and BAM my keys gave different results. Google. Got this answer. Did the control menu sequence. Solved. Thanks.
5
Thank you
you could type the 2 shifts at the same time. One by one but fast
5
Thank you
Fantastic - both holding shifts solved the problem. Thanks for posting the answer :).
that was the shits bit of andveive ever
Black Skull - Oct 11, 2009 at 09:17 AM
5
Thank you
Gennie. Thanks very much. That solve the small problem I had. Handy to know
3
Thank you
Thank you. Simply hold two shift buttons for 5 seconds. God damn bill gates and his cronies with this windows crap. Hope he pays for it in hell..
1 2 Next